MC7455 GPS no Fix


I am trying to use the GPS of a MC7455, with no success…
I work on ubuntu linux with:
Manufacturer: Sierra Wireless, Incorporated
Model: MC7455
Revision: SWI9X30C_02.24.05.06 r7040 CARMD-EV-FRMWR2 2017/05/19 06:23:09
MEID: 35907206321118
IMEI: 359072063211185
FSN: LQ842642370110

The GSM works correctly.

I can get NMEA messages on the ttyUSB1 but they never contains any time or position data, no fix is ever made.
Sometimes the NMEA shows that up to 13 satellites are found. I then waited for hours but it never gets data.
I test with two different types of antennas on different PC, and I tried two different MC7455 with no success.

So far I did:

  • disabling NetworkManger and ModemManager --> no changes

  • at!gpsstatus? -> it always respond the following answers (the second one after a while):

    Current time: 1980 01 06 6 00:03:41

    1980 01 06 6 00:03:41 Last Fix Status = NONE
    1980 01 06 6 00:00:03 Fix Session Status = ACTIVE

    No TTFF available

    Current time: 1980 01 06 6 00:13:10

    1980 01 06 6 00:00:00 Last Fix Status = FAIL, FAILCODE = 0
    1980 01 06 6 00:12:48 Fix Session Status = ACTIVE

    No TTFF available

  • at!gpstrack? -> it always respond ERROR as if the command is not recognized

  • I played with the setting of at!custom: changed the combinations of values with no effects:
    at!custom=“GPSSEL”,0 or 1
    at!custom=“GPSLPM”,0 or 1

  • at!GPSAUTOSTART=1,1,255,100,1 --> no effects
    function: 1
    fixtype: 1
    maxtime: 255 seconds
    maxdist: 100 meters
    fixrate: 1 seconds

  • at!gpsloc? -->
    Not Available

  • at!GPSSATINFO? -->

At the moment I am completely stuck any ideas what I could try?


Hi Raphael,

If you have access to a SWI MC devkit, try with that.
Are you indoors?
Do you get a fix when you are outside?


Thanks for your answer James!

I found out what was wrong, i was convinced to be using passive antennas, but they are active.
When I switched : at+want to 1 it worked