EM7455 - Dell DW5811E (3P10Y) and Telekom HU (TMOHU)

I have a Dell latitude notebook with an LTE modem, which does not work with Telekom (T-Mobile HU) SIM: “No network” :frowning: When installed latest Dell driver package Telekom mobile network changed to “Firbidden”, and, of course “No network”:…
Firmware version: SWI9X30C_02.24.05.06. Any idea?

Does it work for other SIM card?

you can try newer FW:

https://source.sierrawireless.com/resources/airprime/minicard/74xx/em_mc74xx-approved-fw-packages/#sthash.zjRg8KQK.dpbs

Yes, it works with other SIM.
I tried to install the new fw (SWI9X30C_02.38.00.00) , but it didn’t work, Windows shows the same fw version. :-/

what did it show in the command prompt message?

Did you install the latest USB driver?
https://source.sierrawireless.com/resources/airprime/software/airprime-em_mc-series-windows-drivers-qmi-build-5087/#sthash.K731v5OS.dpbs

Yes, (Genericdriversetup_5087 installed).

Start the 9999999_9904609_SWI9X30C_02.38.00.00_00_GENERIC_002.082_000.exe, new window:
FDT version 1.0.1806.0
Awaiting adapter …
Setting images preference …
Resetting …
Awaiting download port …
Download images …
Writing image /
Flashing image -
Awaiting adapter…

… and something other, but windows closed so fast :-/

it did not show any error…
did you check the ATI3 for FW version in the modem port?

Update: clean Windows 10 install, only generic driver installed, fw setup show:
FDT version: 1.0.1806.0
Awaiting adapter …
Setting images preference …
Resetting …
Awaiting adapter …
Checking update status …
Enabling selective suspend …
No need to download any firmware images.

Preexisting images information:
Current:
Firmware:
ImageId: 002.082_000
BuildId: 02.38.00.00_GENERIC
Configuration:
ImageId: 002.082_000
BuildId: 02.38.00.00_GENERIC
Final images information:
Current:
Firmware:
ImageId: 002.082_000
BuildId: 02.38.00.00_GENERIC
Configuration:
ImageId: 002.082_000
BuildId: 02.38.00.00_GENERIC

OEM PRI: 9904336 001.007 Dell

IMEI: ###############

Total time elapsed: 31937 ms.

Images downloaded:

Time to reset to application mode: 31297 ms.

Press Enter to continue …

So the fw upgrade ok. but Telekom HU network stay “Forbidden” :-/

have you verified if the SIM card is OK?

Have you entered the correct APN?

SIm card is OK… And now the Telenor SIm is show “forbidden”… S…t… :-6

Ok. back to Dell driver+FW, It’s working… But COM port/Modem device lost… :-/

You can see here to bring back modem port