EM7421 Setting APN

We are trialing a EM7421 card, but I cannot get it to connect to the network. When I hit connect on the skylight app, “there is no profile set”, but I cannot see where to save any profile I create, and so I cannot set the profile as default.
when I try to create a profile, it auto populates the networks to match the Sim I have, and I have tried multiple Sim cards and different networks with the same result.

I have the latest firmware available and the latest drivers and skylight software.

I’m just not sure where I’m going wrong.
Should I be using AT commands to set the APN?

yes, you can try with AT command AT+CGDCONT first

ok so a new sim same problem,
The AT+CGDCONT? shows an APN set the same as the carrier’s website recommends.

I’ve got Firmware Revision: SWI9X50C_01.14.13.00 883709 jenkins 2022/01/05 07:08:35

I’m starting to think it could be a Windows issue?

have you checked if AT!GSTATUS? is showing attached?

You can also try in linux PC and see if it works

Unfortunately I don’t have a Linux OS running at the moment.
Is there an administrator account to the skylight software where I can set the profiles?

Current Time:  260949           Temperature: 37
Reset Counter: 1                Mode:        ONLINE
System mode:   LTE              PS state:    Attached
LTE band:      B28              LTE bw:      15 MHz
LTE Rx chan:   9485             LTE Tx chan: 27485
EMM state:     Registered       Normal Service
RRC state:     RRC Idle
IMS reg state: No Srv

PCC RxM RSSI:  -75              PCC RxM RSRP:  -104
PCC RxD RSSI:  -98              PCC RxD RSRP:  -137
Tx Power:      --               TAC:         a690 (42640)
RSRQ (dB):     -10.8            Cell ID:     00170b01 (1510145)
SINR (dB):      2.8
+CGDCONT: 1,"IPV4V6","www.vodafone.net.nz","",0,0,0,0
+CGDCONT: 2,"IPV4V6","ims","",0,0,0,0


Not sure if you are really using the correct APN, here says you should use “internet” as APN:

what is the PRI setting you are using?
are you using RMNET or MBIM in AT!USBCOMP?
You can check by


With Windows UI, You can also change APN with MBIM mode:

I recently converted to MBIM mode to solve another issue I was dealing with. this allowed me to connect to the internet for the first time!

however, I find that if I install the Driver package, Windows Drivers Package (Build 5087) everything disappears. is there a different driver for MBIM mode?

what do you mean by “everything disappears”?
What do you see in device manager?

This is before,

And after


No amount of resets or unplugging has helped.

i can see the modem port for AT command communication.
Did you check AT!USBCOMP?

Yes, there is a modem port. unfortunately it doesn’t want to communicate on that com port.

you mean you cannot type AT command in modem port?

when I connect to that port, I get no feedback.
I’ve tried Tera term and AT Command tester, which cycles through the Baud rates without a reply from the modem.

how about COM port 8 or 10?

I can connect to 9, which is the NMEA port, but the AT!usbcomp? command only returns an error.

isn’t COM 10 the NMEA port?

no I’ve just cleaned up a couple of hidden duplicates thinking this was causing an issue, now com8= DM, com9=NMEA , com10= MODEM

com8 +com10, do not connect,
com9 replies with “ERROR”

is that COM9 actually is AT command port?
have you tried just “AT” in COM9?

Yes, Com9 replies “OK“ to the Command “AT”

how about these?