EM 7565 test commands failed

Dears community,
I have trouble during testing an EM 7565 module.

First problem that I solved
I set the modem using AT!DAFTMACT in factory test mode and then send AT!DASBAND=34 to set the frequency band. The modem replayed with !DASBAND: NOT IMPLEMENTED. I read from another post here that this command was old /obsolete.
Than I check the correct FTM commands from an updated Product Technical Specification and the command AT!DARCONFIG.

The current problem for which I looking a solution is:
The AT!DARCONFIG just returns ERROR without führter indications telling what is wrong.

Is there anybody who has an issue about that problem, It will be very great!

Thanks very much in advance!
Helmut

@Oedenburger please I need you help
Please :pray:

How can I use the AT!DARCONFIG command?
The modem just returns ERROR when I am using it. I dont know what it’s wrong. The command or the parameters?
Should I update the Firmware version? I precedently used AT!DASBAND. The error message was that It was NOT IMPLEMENTED:

Thank you!

What’s the image are you using right now?
Please try SWI9X50C 1.0 Release 12 which has added AT!DA series commands into support.
https://source.sierrawireless.com/resources/airprime/minicard/75xx/airprime-em_mc75xx-approved-fw-packages/

Thks @Sierra_JordanZhao,
I have SWI9X50C_01.05.03.00 23e1da jenkins 2018/03/28 22:42:08

That’s an old image, please try the latest one.
You can check the CRN from below link to know which version has added AT!AD series commands into support.
https://source.sierrawireless.com/resources/airprime/minicard/75xx/em75xx-swi9x50c-crn-release-note/

Alright! I’ll do it right now.

Thks

Hi @Sierra_JordanZhao,

could give please some hints how to upgrade the image?

I downloaded [SLQS04.00.18.bin.tar] from https://source.sierrawireless.com/resources/airprime/software/linux-qmi-sdk-software-04,-d-,00,-d-,18/ and [SWI9X50C_01.08.04.00] from https://source.sierrawireless.com/resources/airprime/minicard/75xx/airprime-em_mc75xx-approved-fw-packages/ then run the command sudo ./bin/fwdldhosti686 -s …/…/build/bin/hosti686/slqssdk -d 9x15 -p /home/espu2/Programming/eSPU_2/install/SWI9X50C_01.08.04.00_VERIZON_002.015_001 on the terminal but the get endless Unable to find device …

Great thks to your help.

See the capture below.

First, please check if the drivers are well installed in your Linux PC. (GobiSerial & GobiNet)
Second, check the device node.(ttyUSBx & qcqmix)

Hi @Sierra_JordanZhao,

I checked and install GobiSerial and GobiNet

But couldn’t see and install qcqmi

Then I retry to upgrade the image. The result is still the same like in my previous comment

I hope you can follow me and give fürther hints

Thks very much

Please run below command in terminal and see if you can see GobiNet interface.
jordan@X240:~/Downloads/backup$ lsusb -t | grep GobiNet
|__ Port 2: Dev 16, If 8, Class=Vendor Specific Class, Driver=GobiNet, 480M
Then, you can see qcqmix interface.
jordan@X240:~/Downloads/backup$ ls /dev/qcqmi0
/dev/qcqmi0

1 Like

Hi @helmutn
If you see qcqmiX and ttyUSB ports, you do not need to specify “-d 9x15”. The tool will identify the correct modem automatically. If you do use it, it should be 9x50 for EM7565.