Eclipse and Header files (*.h)


#1

Hi you all

I’m experiencing with openAT 4.20 on the Eclipse platform. I’ve been using Visual Studion 2005 with great success, but I wanted to try it out with Eclipse as well. I’m using Eclipse version 3.3 and CDT plugin version 4.

The platform is working just fine; creating project, compiling, building and debugging, but the only problem is the header files (.h). Using VS2005, both the src and inc directories appear in my project window and I can as well read the *.h files and change them. That is apparently not the case in Eclipse. The src directory is there as it should be, but the header files appear in the out [TARGET] directory and are only available for reading. I can not change the code and recompile.

Does anyone recognize the problem?

With regards
Palsson


#2

Just by way of information, I note that the v3 tools seem to copy all the .c and .h files into the gcc\out folder when you build…

Don’t know if that helps you at all… :question:


#3

Hi awneil

Not really :slight_smile:
I don’t know about others, but in VS2005 the .c and .h files get copied into the gcc/out directory!

Funny thing, why eclipse projects doesn’t keep the directory structure of src and inc.


#4

It’s actually the Wavecom makefiles that do it, rather than VS itself - and only for a Target Build using GCC;

The Remote build (using the MS native compiler) doesn’t copy anything to the gcc\out folder

Still doesn’t help you. though, I guess… :frowning:


#5

Hi awneil and others

Apparently the new build of C/C++ development tool, CDT 4.0.,1 is the reason for the problem with header *.h files in Eclipse. If I use earlier builds, i.e. CDT 3.1.2 its working fine.
I installed the latest builds of both Eclipse and CDT in the beginning, and then I became aware of the problem. On a different computer with Eclipse 3.2.x and CDT 3.1.x things were working fine. So I tried with earlier build of CDT on the latest Eclipse, and its working.

Is there anyone working with Eclipse and openAT?

Regards
Palsson