Dwlwin for gl6110?


#1

Hi,i can’t seem to get dwlwin for gl6110. I referred to this article - sierrawireless.custhelp.com/app/ … ugh-dwlwin

Firstly, the Wireless CPU GL6110 doesn’t exist in the dropdown menu for Wireless CPU.

Secondly, the firmware R7.44.0_gl6110.dwl, can’t seem to be loaded as the extensions allowed are only .bin, .wpb, .e2p and .cus.

I’ve attached a screen capture. Looking forward to any tip, thanks.


#2

for GL6110, you need to follow the instruction in http://sierrawireless.custhelp.com/app/answers/detail/a_id/777 to download the dwl file over x-modem.
In order to download using dwlwin, you need to access the boot pin. You can’t do it through the USB cable of GL6110. So, you can use dwlwin.


#3

Hi SPI,

Thanks. I tried that but it doesn’t seem to return the NACK characters after typing “AT+WDWL”. Here’s a screen capture. A note, i’m using GL6110, the USB version.


#4

AT+WDWL causes the unit to restart - so windows loses the COM port.

Therefore, immediately after typing AT+WDWL, you have to “disconnect” in Hypoterminal, then wait for the unit to restart, then “reconnect” once it’s restarted and the COM port has reappeared - then you should see the prompts.

You can listen for the Windows bing-bongs to know when the port has reappeared, and/or watch it in Device Manager…

Note that downloading via DeveloperStudio copes with this automatically…


#5

Hi awneil , thanks, this worked. It should be included in the official documentation.