DS 2.3.0: Useless "Install Error" message


#1

A fesh install of DS 2.3.0, trying to add the Open AT Embedded Software Suite package 2.36.0.201108300638

How unhelpful is that?! :unamused:


#2

Sure that the message could be more explicit.
Anyway, such kind of error occurs either because of a temporary server/connection unavailability, or… because of an unexpected bug…
Is the issue reproducible?
Please could you post the error log here?


#3

Yes - the connection was being “flaky” at the time.

Looking at the Package manager afterwards showed that some components had been updated, and some still needed updating.

It would have been a lot more helpful if the message had been explicit - and shown how far it had successfully got…

Repeating the update on the “missed” components worked.


#4

Yes, we’ll have a look to improve that