DNS and SMTP not working properly


#1

Hi,
I have a M1306B with the following WIP version installed:

WIP Soft v301 on Open AT OS v313
Sep 28 2007 14:53:28 WIPlib:v3a02 WIPSoft:v2a07

I’m working with the WIP AT Command set to obviously do some internet things, mainly sending email via smtp.

In trying to do this I’ve come across two problems… The first is DNS related, I can ping an IP address, but can not ping a domain name.
If the ping does return from a domain name ping it returns a time out (+WIPPING: 1,0,0)

The second issue is with smtp, I think the email is not getting formed properly, and not sure if it is me.
I followed the basic outline of the example in the WIP AT Command pdf.

Here is where things go strange:

What happens here is that the email subject and the data get merged together, like this:

[/quote]
Am I doing something wrong?


#2

Yes, I have also had problems that DNS doesn’t seem to work (properly) with WIP. :frowning:

It seems to be a common problem:

viewtopic.php?f=37&t=1862&p=6807&hilit=DNS#p6807

viewtopic.php?f=16&t=1686&p=6213&hilit=DNS#p6213

viewtopic.php?f=16&t=1399&p=5128&hilit=DNS#p5128

viewtopic.php?f=16&t=1386&p=5078&hilit=DNS#p5078


#3

Thanks for the reply… at least it’s not just me having DNS issues…

Has anyone tried the SMTP commands?


#4

Hi…

I tried the SMTP commands too on a G-F4 modem, and got exactly the same problem : topic and body of the mail are merged when I receive the message in my mailbox. :open_mouth:

I tried to get more infos from my provider, but didn’t get any result. Most european support teams told me SMTP commands were not available for that device and that firmware (well, I had evidences that they were wrong), and the US support finally told me two weeks ago that they managed to see the same error in their lab. Well… Congratulations, guys !

For the moment, I feel like giving up : my opinion is that the new firmware with SMTP support is just a beta (or maybe a gamma :wink: ) version and that it still needs to be improved. Not sure I’ll keep on trying to use that modem on my design (I need to have working emails functions before the end of the month).

Anyway, I’ll warn you if I get some more infos (please do the same for me).

Best wishes,
Christophe.


#5

Still nothing new about how to send correct emails ? I’m surprised that so few people need this function… :frowning: Don’t let me be the last to know when it works !!! Please please please !!! :blush: :wink:


#6

I think it should be your distributor’s job to keep you informed…


#7

After finally getting around to looking at this problem again… I got a new firmware and WIP from my distributor.

Sending plain text emails now seems to be working properly (only tested it twice :smiley: ).

The versions that works for me are:
Q24 with firmware 6.57e
WIPSoft 3.11

So half my problem is fixed…
DNS still appears to be broken… Ping of an IP is ok, ping of a domain name fails

Tried to send a MIME formated email, but that didn’t work… need to check I formed it correctly…


#8

Hi,
I have a F4 Quad Band modem and I was trying to do SMTP commands. I am trying to use the command AT+WIPFILE=6,1,2 and I get CONNECT response back. I type a sample text message (which doesn’t appear on my HyperTerminal Screen) and press Ctrl+C (ETX) character and comes back with OK. I get an e-mail soon, but there is no body in my message. Can someone tell what I am doing wrong?.