Digital Audio Interface / PCM Interface


#1

If I use at+speaker=(5-8), I get noise on either speaker (SPK1 or SPK2 based on setting). I can reduce the noise by adjusting at+VGR; however, I can’t get audio at any setting via PCM interface on data slot 0. I can send audio to the the GSM connection on the PCM interface slot 5. Is there a setting that is required or the WCPU needs to be put into a mode other than the at+speaker=5 mode. Behavior is the same on the Wavecom Development board and whether or not my application is running.

I hear audio clearly on SPKx when I use settings at+speaker=(1-4). MICx both work as well.

Also, I see data on PCM-IN (pin 78), slot 5 when using at+speaker=5-8. Is this expected?

Thanks,
Jim