Can not use MIC_2 as single-ended interface


#1

Can MIC_2 be used as single-ended interface in the module Q2438?
I have sent : AT+SPEAKER=1
But it did not work.
When I used the same circuit on MIC_1, and sent: AT+SPEAKER=0, it worked well.
Why?


#2

Very confusing API from Wavecom.

AT+SPEAKER=1 directs audio to AUDIO2 port
AT+SPEAKER=2 directs audio to AUDIO1 port.

My only guess is that something is lost in the translation from French :wink:


#3

somehow, I have the very same problem!

in the AT command user guide (version 7.1 or 7.4, no difference), it is said that “AT+SPEAKER=1” means MIC_1, Spk_2 but when I set configuration to “AT+Speaker=1”, just MIC_2 and SPK_2 are active!

any common experience or idea how to set configuration like the User Guide?


#4

hiiii

In the documentations, AT Command Guide and WMP Dev Kit,the references to audio inputs and outputs are different. This makes confusion for us who want to configure these I/O. The confusion is faced because it is mentioned that Audio 1 and Audio 2 can be selected on the Wireless CPU. But Audio 1 and Audio 2 refer to the connectors available on the demo-board, and not on the module.

Actually, the description should be something like this:-
E.g. :
Audio 2 (on demo-board) :
Mic (from UGD) = MIC2 (from PTS/Dev Kit)
Hfr (from UGD) = SPK2 (from PTS)

Audio 1 (on demo-board) :
Auxmic (from UGD) = MIC1 (from PTS)
Ear (from UGD) = SPK1 (from PTS)

I guess the issue has been raised with wavecom and the documentation would be corrected soon …

hope this helps…
cheers :smiley:


#5

Hi there,

then could you check this message too?

http://www.wavecom.com/modules/movie/scenes/forums/viewtopic.php?f=45&t=3974


#6

The documentation is still not fixed. (I agree with bandali’s comments above)
AT command guide has at+speaker settings incorrect.
at+speaker=1 and at+speaker=3 should be swapped.

Unfortunatly I found this mistake after wasting a lot of time and effort.