development board: UART1


I’m using the development board with an HL8548. I can connect to the GSM module through USB and issue all AT commands I want.

But, I can’t use UART1_MAIN: no response there. The user manual mentions that the UART1 might need activation. Can you tell me how to enable communication over UART1? Are the UART settings 115200 8N1 too?

Furthermore, in the future we want to integrate the HL8548 to communicate with our microcontroller over UART too (not over USB). Is this UART available out-of-factory?




Uart default settings is indeed 115200, 8N1, and is available out of factory (at least for the ones I used).
I don’t remember any trouble with dev board to use UART1.

Did you try to cross RX/TX lines ? Pin5 (UART1_TX) is an input, while Pin6 (UART1_RX) is an output. Signals are named from PC/Microcontroler view, which was a bit confusing for me.

Thanks for your reply.

But: I tried to use both a straight UART cable and a null modem cable to connect to the board. Still no response on my AT commands on that UART. For me, it really seems that that UART is disabled in firmware, as mentioned in the development kit user guide:

As said, I’m using the HL8545. Which ones are you using?

Anyone any clue?

I’m using HL8548-G.
A few weeks ago, I have loaded the last firmware from the website, (which probably mean factory reset), and I don’t have any trouble to access the uart using a microcontrôleur on a custom board. I have never used USB on this board to send AT commands, just for firmware upgrade, so I’m pretty sure UART is enable by default.
I just tried on the dev board using USB/Serial cable on CN700, and I’ve got the same problem, no reply from the board. Not sure what’s wrong, I’m pretty sure I already used uart on this board (at least using CN202 connector, with an FTDI chip).

OK, I tried an FTDI to RS232/TTL cable straight to the CN202 and that works! Strange indeed why the CN700 doesn’t work…

tnx for your tip!