Developer Studio v2.1.1

Ok, got it… You’re probably not on a WMP module, and we’re not managing extended error codes in the target model loader :frowning:
We’re working on a patch to fix this ASAP.
Thanks for the investigation.

PS: to attach any file on the forum, please just zip it (best way to be sure that it will be accepted)

I am still having issues with uploading application firmware to the FXT009. Dsk_5’s solution of AT+CMEE=0 and AT&W did help but I still get issues when uploading application firmware. The firmware uploads okay then a command is sent to the FXT009 to reboot and this causes the CMEE to reset to 1 causing the rest of upload process to hang during the “Load model element: Target Informations” portion. By hitting cancel, resetting the modem and setting CMEE=0, I can continue working but I need perform the cancel/reset operation every time I upload new application firmware. Has anyone worked around this or is there a bug fix?

Hi all,

Please find attached a patch to fix the target info loading bug when AT+CMEE=1
To install the patch:

  • Go to Help > Install New Software
  • Drag’n drop the zip file in the dialog
  • Uncheck the Group items by category box
  • Select the Patch for Target Manager item
  • Click Finish and follow the steps

From there, Target info loading shall run correctly, even if AT+CMEE=1 mode is enabled (89 KB)

Thanks Daav! The patch worked.