Dev Studio 1.1.2 Downloads Broken?

I have now downloaded the Full Installer twice (on 2 different PCs), and neither one works! :angry:

On one PC, it gives an error dialogue: “Extracting error: SFX Header invalid”

On the other, it just does absolutely nothing at all.

Both PCs are WinXP-Pro + SP3.

In both cases, the download completed without error - but the 1st one is 370MB (388,600,000 bytes) and the 2nd is 409MB (429,100,000 bytes).

I used the download link given here:
ie, … tudio.aspx

The “Light Installer” doesn’t work either - its choices for installation folder are empty!! :unamused:

And, in my M2MStudio 1.1.1 ‘Packages Manager’, there is nothing listed under “Default Wavecom Repository []”

See also: :question:

If I do Help > Check for Updates it just says, “Cannot complete the request. This installation has not been configured properly for Software Updates”

So I seem to have an abject failure of all possible routes to update?!

OK, just done it again on another PC (XP-Pro+SP3 again) and got yet another different-size file that doesn’t work! :angry:
This time it’s 384MB (402,800,000 bytes).

I note that these are all HTTP downloads where the downloader doesn’t seem to know the download size in advance:

As has been frequently requested before, is there a proper FTP site somewhere from which I could download this?

the fucking website of SW doesn’t support resume download :smiling_imp:
the size of 1.1.2 Full is 529 MB (554,863,936 bytes)

Sometime back it took me 1 week to download the full install file.
Below is the size info for the one i have.

Usual response is get it from your distributor. :slight_smile:

Ideally a download manager app should download the file in smaller chunks (with resume download from the point of disconnection). This is seen in many install apps, so it must be simple enough to implement.

They don’t have it, either!

Just straight FTP would do!

This one worked for me a few weeks ago:

We had troubles in the site hosting one or two weeks ago, and this explains the issues encountered with the installer.
However, please note that we are aware of the recurring issues with the downloads, and we are currently working on a new hosting solution.

I tried to download and install “Sierra_Wireless_Software_Suite_Full_Installer_v2-33.exe”, I am still receiving the same "Extracting error: SFX Header invalid”. Are the hosting problems still continuing?

I’m having problems too.
I’ve tried fresh download of 1.1.2, upgrade from 1.1.1, full installer, light installer. The error dialog indicates its having problems downloading components.
However I can download the full installer as a complete file and get the 529 MB file. It seems to install the plug-ins but not the main executable. If I try to install again, it says that its all ready installed (i.e. there’s a directory there, but it’s not doing anything, it needs repair)

OK, got there in the end after hours of waiting for downloads and trying different options.
I deleted the previous directories from the failed installs.
I downloaded and saved the Full installer. 529MB
Turned off anti-virus protection.
Ran the installer in internal mode only (no internet connection required). This completed OK.
Started up the 1.1.2 Developer Studio, it indicated upgrades were available so I started these.
The install packages now completed OK.

Imported my existing project. And lo … I have 525 errors all of a sudden. Joy. Have to work out what files are missing/renamed.

OK, imported all the previous packages and installed those and we’re compiling again. Phew!

Next Update:
The Editor has now failed with “Initialize Indexing” java.lang.NullPointerException
I’ve had to reimport the project again and merge my changes back into the project. Fun, fun,fun!

Looks like it’s broken again:

And again:

OR should that be, “still” ?

Please take a look at this post: Developer Studio 1.2.0 beta has been made available from a new hosting solution, that we hope quite better than the current one.
Don’t hesitate to have a try, and report us any other issue.

(NB: only Developer Studio will be downloaded from there, Open AT Embedded Software Suite is still retrieved from the current production update site)

Well, it is certainly better in that my browser now knows the size of download to expect. :smiley:

The fundamental problem with the other site was that it did not know what size to expect - so there was no way to know whether the download was complete or not! :unamused:

Интересный вопрос к рукодителям фирмы,
Ваша фирма продает устройства и предоставляет бесплатный софт для разработки
вот только одна проблема, раз софт бесплатный то его не скачать

ВОПРОС почему ???