Debian 11 Bullseye

Hi, I installed leaf and created a workspace. Then I tried to install
$leaf setup wp76stable -p swi-wp76_1.0.0
→ I get an error at the “leaf profile sync” step
Downloading 8 package(s)
[1/8] Installing wp76-toolchain_SWI9X07Y_02.37.07.00-linux64
Run install steps for wp76-toolchain_SWI9X07Y_02.37.07.00-linux64
Configuring the toolchain for your environment, this may take a few minutes…
Error during installation: Error during install step for wp76-toolchain_SWI9X07Y_02.37.07.00-linux64 (command returned 1)
Profile provisioning interrupted
Error during install step for wp76-toolchain_SWI9X07Y_02.37.07.00-linux64 (command returned 1)
try leaf profile sync to resume
Command exited with 2
Sub command failed: ‘leaf profile sync wp76stable’

Also, if you try
leaf getsrc legato
you will see an error about python-git and python-xmltodict
but I have python3-git installed. And I installed and tried each python-is-python2 and python-is-python3 and it still didn’t work.

I saw this problem in VSCODE to download some package, but once I change to swi_vs_support_200304 in VSCODE, then the installation is OK.

Not sure if you can try in VSCODE.

BTW, i used python3 version 3.6

Oh yeah, you can install leaf packages using VSCode too. I didn’t think of it. I just tried it in shell. I will try it. Thx.

Same thing. I mean it just opens a shell in the VSCode IDE and runs the same command. Also I am using sdk package swi-wp76_5.0.0 and the support tools package is for older versions of the sdk. I tried anyway, v200304 and the newer one v200624. Both return error, same error as before.
Command exited with 2

btw debian 11 current stable has python3.9 and python2.7

I used to try swi_vs_support_200304, and it is working fine on Ubuntu 16

16 works better than 18?

I tried ubuntu18, it is also working for me