Compiling and debuging using Eclipse


#1

Hy all, :bulb:

I am able to compile an Open AT project using Eclipse (see below how I do it ).

Now, I would like to use the debug mode but I do not have idea how to set the Eclipse enviromment to do that !!! ( I do not know even if it is possbile ! ).

Anyone knows something about it ?? :question:

Tks,
Gus

/*****How to set Eclipse enviromment

01 - Create a project using Open AT Project Wizard
02 - Open Eclipse
03 - Click File->New->Project
04 - Select C->Standard Make C Project (you need to install CDT plug-in first)
05 - Click Next, put a name to your project and finish it
06 - Click File->Import
07 - Select File system (click Next)
08 - Browse your project directory
09 - Click Select All and then Finish
10 - Click Project->Properties->C/C++ Make Project
11 - Uncheck “Use default” and complete the following fields

Build command: wmlauncher.bat wmmake
Build (Incremental Build): ${project_name}
Rebuild (Full Build): ${project_name} -c

12 - Click OK
13 - Click Project->Build All to see it working (see the output on Console windows)


#2

Hi Gus
What version of openat are you using?
Only the latest version of openat supports debugging in eclipse
V4.10beta4
If you are using the latest beta version then use these steps
While your project is open
click Project->Build All
click run->run…
under the C/C++ Application:
click Browse…
and select the file
\mingw\out\kernel.exe
e.g.: (H:\Dev\OpenAT\V410b4\Hello_World\mingw\out\kernel.exe)
and then select run
it will start the RTE now

Best regards
Walter


#3

Walter,

Before you run the kernel.exe dont you need to compile the project ?

As fas as I know it is different from target mode.

Do you know how to compile the project before run the kernel.exe ???


#4

Hi Gus
I have attacheda screen shot of how to build for RTE
Best regards
Walter


#5

How can I get V4.10beta4 version ?
I am working with V4.10beta1 !

Thanks.


#6

Hi Vincent
You have to call your distributor.
They should be able to give it to you.
Best regards
Walter


#7

Hi,

I have started to work with OpenAt V4.10 Build 5 but I cannot install it correctly. I’m trying to build the Hello World example and it fails, with some extrange errors.

  • 00 [Time = 00]

  • enter new zip file comment *00:00

  • enter new zip file comment * DiagnoseTips.ini (152 bytes security) (deflated 87%)

    All the errors in line 0.
    I have followed the steps described in older posts, so I am very confused.

    Any ideas??

    Best regards,

    Alex


#8

Hi everyone,

I have the 4.1 b4 openAt, I have installed everything and the wmcheck seems to be good. When I try to create a new project with the wizard, no errors occur. It lauch Eclipse but there is nothing created like the screenshot above… Did you done that manually? If yes, what is the configuration in wismo target mode and debug mode, how can I include the Wavecom header files?

In the cd I received from my Wavecom distributor, there is no documentation about eclipse. If someone have a pdf, can you send me that? I have asked a doc to my distributor but without responses at this time…

Thanks

Best regards

gdt


#9

Hi,

I am using Open AT ® OS Release version: 4.10 Build 10 which came with Open AT ® IDE Release version: 1.00 Build 06. (I think for IDE there is already a newer version :question:)

The project wizard did not create the settings suitable to debug from eclipse, and only does support elipse (no selection for other IDEs possible).

Following the walter_senekal’s instructions, I can run the RTE. But I am not able to debug. When I try the same for Debug, I get an error “Error creating session: Exec error:Launching failed” and when I click on Details>> I will get

Exec error:Launching failed
  Exec error:Launching failed
  Exec error:Launching failed

which doesn’t really help a lot.

Did anyone came across this problem and found a solution to that?

Thanks in advance,
Jan


#10

Hi

I have installed V4.1 b4, V4.1 b7 and now I’m on V4.1 RC1. I have noticed that with the 4.1 version, Cygwyn is not installed? Is this normal?

When the project wizard creates the files, it cannot find the .metadata file, and as a result Eclipse starts with a blank workspace. How do I fix this?

Thank you

Regards,
Geoff


#11

Hi

I have installed V4.1 b4, V4.1 b7 and now I’m on V4.1 RC1. I have noticed that with the 4.1 version, Cygwyn is not installed? Is this normal?

When the project wizard creates the files, it cannot find the .metadata file, and as a result Eclipse starts with a blank workspace. How do I fix this?

Thank you

Regards,
Geoff


#12

Hi again,

Just wanted to let you all know that I found my problem… The path to the “gdb” executable wasn’t set right… A more specific error message would have been helpful…

I think what it does is that it installs a very private copy of cygwin in its OpenAT folder… If you haven’t changed the installation directory, look in C:\OpenAT\IDE\IDE\1.00.06\cygwin… And yes, I think this is normal…

Best Regards,
Jan