+CMTI not received if sms send while FX100 is power down

Hello,

I’m a newbie (first step) in the AT protocol and with FX100 module.

I connect the FX100 module with rs232 connection to a pic (microchip), the communication seem to be ok.

for testing some AT command, I use a hyperterminal connection (rs232 with a windows 7 pc).

no problem for giving the code pin and for sending a sms.

I received the +CMTI response from the FX100 if I send a SMS to the FX100 module with my smartphone

but if the FX100 is power down (or I thing aloso if the AT+CQS command response less than 10,0), this sms message is loss.

I check the sms list with AT+CMGL=“ALL” and this sms never appear on the list.

I have the same problem if the memory of the sim card is full.

Have I miss a parametre command ?

thanks for your help.

Obviously, no device can receive messages when it is switched off - whether it’s a phone, an FXT, or whatever!

Similarly when a device - any device - has insufficient signal.

But the message is not lost - it is held by the network until it “sees” the device again and can deliver it.

But see: https://forum.sierrawireless.com/t/sl8090-synchronisation-indication-for-sms-retreival/7320/5

Again, this is standard behaviour - whether for a phone or any other device.

But, again, the message will be held by the network until it can deliver it.

I suggest that you enable delivery notifications on the sending device - then you’ll know when the network has delivered the message.

Networks do put a maximum limit on this - but it would be many hours, or even days.

Some phones allow you to adjust the limit…

tanks for your help,

here is my settings do you think it is correct ?

+CNMI: 0,1,0,0,0

and for information all message are store in the sim card
+CPMS: “SM”,0,10,“SM”,0,10,“SM”,0,10

I use an old sim card with a very small capacity of message (10), a new sim card can change something ?

By “sending device”, I mean the device which you use to send the SMS - ie, your phone.

You say you’re using a smartphone. Then the setting will, surely, be in a menu - not AT commands :question:

https://forum.sierrawireless.com/t/how-to-send-an-sms-message-from-a-pc/1442/2

A newer SIM card will almost certainly have more storage capacity

Sorry for the mystake,

I have set the acknowledgment of receipt (and all notifications for sms) on my phone.

I have test it:

1)FX100 is power off and I send to it a sms (with my phone and with acknowledgment of receipt)
-> the phone wait the acknowledgment (not yet received)
2)FX100 is power on
-> when the pin code is sending to the FX100 with at+CPIN=xxxx the phone receive the acknowledgment but the FX100 nerver show the message (no +CMTI command received)
with the command +CMGL=“ALL” I can’t see the new sms in the list.

I have try this settings :
+CMGF=1
+CSMS=0,1,1,1
+CNMI=2,1,3,1,1
+CSMP=49,169,0,0

the AT+CSCA is correct because I can send sms without any problem

I have save the settings with AT+CSAS

I thing that the FX100 received the sms from the network (because the phone show the acknowledgment) but I can understand why the FX100 doesn’t show this message ???

Is there an Open-AT application running in the FXT that “consumes” the message?

Have you contacted your Distributor or FAE :question:

I have just take contact with my distributor “SPHINX France”.

Excuse me, but, what is a FAE ?

FAE = Field Applications Engineer.

If you were a direct customer of SiWi, you would get support from their FAE(s)

thanks,

I have checked it with the command AT+WOPEN=7 and an open-AT application which was running.
I have tried the command AT+WOPEN=0 to stop this application,
restarted the FX100 with power down/on and now the FX100 sends some +WIND:xx information
but I still don’t receive the sms sent from the smartphone if the FX100 is powered down.

Is it possible to do a factory reset ?
(for resseting all parameters with it initial value)

I have find the solution,

the problem is that the sim card is not immediatly ready after AT+CPIN=xxxx

I see that because just after pin code insertion, the commande AT+CMGL=“ALL” response with error until the sim card is ready.
the problem is that the network send the sms just after the insertion of the pin code and can’t write it in the sim card.

I have change the memory location for read and send sms to memory flash with
AT+CPMS=“ME”,“ME”,“ME”

and now I received after power up and just after the pin code insertion the +CMTI:“ME”,x indication

I don’t know if this is normal that the sms is lost if it is must be save on sim card.

tanks a lot for your help.

No, that shouldn’t happen.

As in the case that the SIM is full, the network should keep the message & retry.

However, as noted in the previously-linked thread, there will be a delay before the network retries - possibly a long delay.
So maybe you were just being impatient…?

I don’t thing the networks will retry to send the sms again because the smartphone (the sender) receive the acknowledgment that the sms is read?

Vincent.