Can't connect to Fastrack GO USB


#1

It’s not possible to connect to a Fastrack GO USB device with expresso. The first step in the connection process goes ok, but for some reason this is not the case for the second step! I get the message ‘You tried to communicate with your target, but you are not connected. Adjust your connection’s settings and hit the “Connect” button.’! I tried all different baud rates and still it doesn’t connect to the device!

In the release notes I see that there’s a known issue with the Fastrack GO USB. Is this the ‘known issue’? If so, any update on when this is going to be solved?

rgds,

Ralf


#2

Hi Ralf,

There are indeed some known issues with Fastrack GO USB device. We will try to fix this for the version 1.2 planned for mid-December.

Regards,
Jacques


#3

Hi Jacques,

Thanks for the answer, but I was wondering if there will be a testversion of the firmware available before mid December to try out? I reall need the Fastrack GO USB working in the next couple of weeks and with the current firmware version is this impossible.

rgds,

Ralf


#4

I think the issue was with Expresso (PC software) - not the firmware (in the Fastrack) :question:

So just don’t use Expresso - use a “normal” terminal program?

See above - I don’t think it’s a firmware issue?


#5

Sorry my mistake! Instead of ‘firmware’ I actually meant ‘driver software’!

Also with a ‘normal’ terminal software program like Hyper terminal the Fastrack GO doesn’t work!


#6

More detail required!


#7

More details:

I can connect to the GO with hyper terminal (at least it looks like it, I can choose the right COM port with the appropriate settings) and it actually says ‘Connected’, but if I send the ‘AT’ command I don’t get the response ‘OK’.


#8

well, connected doesn’t mean anything with hyperterminal, it just means that the port is opened.