developer studio usb device


#1

using developer studio, is correct that usb device is not seen in target device management?
I attached my wavecom fastrack supreme with usb and I got /dev/ttyACM0 as device

thanks

Luca


#2

My Fastrack’ USB appears as a COM port with DS 1.2.0 on Windows-XP.

I take it you’re on Linux?


#3

USB devices are not supported under Linux (neither USB-serial converters, nor “pure” USB connections) with DS 1.2.0
It’s still planned to add this support in a future release (not the next one, which is coming shortly, but probably the one after).


#4

I’m using Developer Studio “Base Plugin 2.1.0.201108051602 R6790” with Ubuntu 10.04 and the USB support does not appear to be working yet. I can use the ttyACM0 port with both Kermit and Minicom but the ttyACM0 port is not recognised at all by Developer Studio.

Do you have a workaround please? We need to use the USB port for Developer studio so that Serial Port 0 is available on the Fastrack Xtend for an FCM device.


#5

I use Debian GNU/Linux wheezy/sid :

lqman@development:~$ uname -a
Linux development 3.1.0-1-686-pae #1 SMP Sun Dec 11 20:40:16 UTC 2011 i686 GNU/Linux

and successfully use the USB device with this little trick :
my linuxbox recognize usb device as /dev/ttyACM0, then I create symbolic link into /dev/ttyUSB10

lqman@development:~$ ln -sf /dev/ttyACM0 /dev/ttyUSB10

Then, in the Target Management perspective, click Refresh the available serial ports, and /dev/ttyUSB10 is appear and can be accessed as serial port /dev/ttyS0, etc.
But there is little buggy, whenever the device is restart with AT+CFUN=1 or power-cycling, my linuxbox recognize it as /dev/ttyACM1, /dev/ttyACM2, /dev/ttyACM3, etc.
Maybe it can be solved with adding rule to the UDEV, but I choose to use another tricks. Create the symbolic link for /dev/ttyACM1, /dev/ttyACM2, etc.

lqman@development:~$ ln -sf /dev/ttyACM1 /dev/ttyUSB11
lqman@development:~$ ln -sf /dev/ttyACM2 /dev/ttyUSB12
lqman@development:~$ ln -sf /dev/ttyACM3 /dev/ttyUSB13
lqman@development:~$ ln -sf /dev/ttyACM4 /dev/ttyUSB14
lqman@development:~$ ln -sf /dev/ttyACM5 /dev/ttyUSB15

and this 6 symbolic link is enough for me.

Try it and give me feedback…


#6

Thanks for the tip!
We’ve not solved all the USB issues under Linux, so far, but such kind of trick will help to be patient until then :wink: