Can not building projects in headless mode with DS3.5

Hi everyone,

Recently when I upgrade my Developer studio from DS to any later DS version, for exampe DS3.5 (Build Version, I can not build projects in headless mode anymore, even if install new DS in different folder.

Here is my setting:
Build command:
C:\DSTemp already created in C drive,
All packages already installed in Packages manager.
Open command prompt: change dir to E:\DS3.5.M1.201506190944\DeveloperStudio, then run command:

devstudio.exe -nosplash -consoleLog -application com.swi.ebs.commons.core.buildmanager -data C:\DSTemp\ -create hello_world -sample hello_world -pkgRef "Firmware Package (" -pkgRef "Open AT OS Package (" -pkgRef "Internet Library Package ("

Error display as below:

And a popup windows showed:

E:\DS3.5.M1.201506190944\DeveloperStudio>java -version
java version “1.8.0_45”
Java™ SE Runtime Environment (build 1.8.0_45-b15)
Java HotSpot™ Client VM (build 25.45-b02, mixed mode, sharing)

I don’t know what wrong with later DS (from, it works on this version)
I will greatly appreciate if anyone help me. Thank you very much.


Note sure if this applicable - but there is a note in the Release Notes that you will need a 32 bit version of Java installed even if you are running a 64 bit system.

I also note that you are running Java 1.8, but the error message is stating that Java 1.7 is required. Can you install an (old) version of Java 1.7 and see if you get the same error?

ciao, Dave

Hi Dave,

Yes, I get the same error.
removed java1.8 and install 1.7 but the error still exists,

I can confirm that java 1.8 worked with DS before, but now it can not (for both &


Have you also got a 32bit version of java installed?

Ciao, Dave

I choose windows x86 version for both jre and jdk
(jre-7u80-windows-i586.exe, jdk-7u80-windows-i586.exe)

Regards, Giang

(By the way, please note that DS 3.5 is not an official version yet; fixing the topic title :wink:)

Since DS 3.4, in headless build, a new option has to be provided on the command line to specify the module to be used for the project; e.g.:

-module SL808XT

But it’s true that the documentation was not updated on this particular point; fixing it ASAP for the (real) DS 3.5 release.