caller's number isnt shown


#1

hi,
i have two fastrack supreme 20 modem named modem1 and modem2.
i call modem2 from modem1. modem2 has already run the command at+clip=1 so he can know the caller’s number.

when i run atdt [modem2’s tel number] , i get +CLIP: “1013”,128 on modem2.

i expect +clip: “modem1’s number”,129 but i cant.

i have had no problem with this calling and getting numbers of callers for months. but suddenly now this problem has occured. what can the problem about ?


#2

IF you swap the SIMs in the 2 modems, does the issue follow the SIM, or stay with the modem?

What happens if you call from a differnet number; eg, another SIM, or a landline?

The CLI information is provided by the Network - so you should talk to your service provider about this…


#3

i found that the issue is with SIM. i swaped modems, used different numbers and tried all cases.

i try 4 different numbered,same operator sim card and one of them worked well. %25 persent not too bad. what annoys me about programming is the external things. i think you are right it must be about service provider.

but can i find a documentation about the “1013”,128 response mean? 128 refers to and i found the meanings of only 129,145 but couldnt find 128.


#4

Here’s a good description of the Type-of-Address field:

dreamfabric.com/sms/type_of_address.html

Bit:        7           6          5          4          3          2          1          0
       +----------+----------+----------+----------+----------+----------+----------+----------+
       | Always 1 |         type-of-number         |               numbering plan              |
       +----------+----------+----------+----------+----------+----------+----------+----------+
0x80 = |    1     |     0         0          0     |    0           0         0          0     | = 128
0x81 = |    1     |     0         0          0     |    0           0         0          1     | = 129
0x91 = |    1     |     0         0          1     |    0           0         0          1     | = 145
       +----------+----------+----------+----------+----------+----------+----------+----------+

type-of-number = 0 = Unknown;
type-of-number = 1 = International;

numbering plan = 0 = Unknown;
numbering plan = 1 = ISDN/Telephone plan (ie, a “normal” phone number);

It looks like the network is giving you some kind of “short code”…?


#5

we can not get much information from this table. it says 128 = Type of number(0),Numbering Plan Identification(0) and 0 means not known. And it says about type of number = 0 case

“This is used when the user or network has no a priori information about the numbering plan. In this case, the Address-Value field is organized according to the network dialling plan, e.g. prefix or escape digits might be present.”

i couldnt understand much about this. maybe 1013 means something.

and one strange thing more;
when i call my own phone from modem1, it shows the number. but modems dont.


#6

hello awneil,

we have called the SIM operator to ask this issue. we described the problem. then they called us back and said that they hadnt changed anything can cause this problem. they said the problem may be about our modems.

which procedure should we follow now? have you got any idea?


#7

Unfortunately, the network operator customer “support” lines are usually useless on technical issues like this: viewtopic.php?f=34&t=1106&p=3930&hilit=useless#p3930 :frowning:

You should speak to your Wavecom Distributor - they should be familiar with network behaviours in your territory, and might even have some proper technical contact with the networks…


#8

you are right. we couldnt get enough help. we may ask our distributor maybe he knows something. He must be familiar to this topic (i hope).

thank you by the way, for all the ideas that you share


#9

Yes, the problem is our campany’s SIM cards have been in someting like a subnetwork for short numbering. You warned about short codes but i couldnt understand much at that time. The problem is our campany’s numbers have been made shorter by the SIM operator. So nothing to do with code while we call a campany number from an other campany number.

Thank you for the opinions ,