I’m using the BX310x Development Board with FW 2.5.0.

I want to use AWS IOT platform, with the MQTT protocol., but had troubles with the certificates.

AWS IOT supplies a Root Cert (CRT), Local Cert (PEM) and a Private Key. Uploading the 2 certs was straightforward with AT+KCERTSTORE=0 and AT+KCERTSTORE=1.

Uploading the private key was not: AT+KPRIVKSTORE?, AT+KPRIVKSTORE=0 and AT+KPRIVKSTORE=1 all returns “ERROR”. As if the command does not exist.
After hours I just tried AT+KPRIVSTORE=0 (without the K) and I got the “Connect” reply and sent my file followed by +++. I could not check the file with AT+KPRIVSTORE?, it returns (918 FEATURE_NOT_SUPPORTED).

Dear Sierra Support: Did somebody make a typo in your documentation? Please confirm my findings.

i guess that is typing error…

BTW, does the latest FW 2.6.3 fixed the query problem?

I have updated my BX to the latets FW 2.6.3,.

The typo in the AT command has been fixed AT+KPRIVKSTORE=0 works now, but the query AT+KPRIVKSTORE? still returns +CME ERROR: 918