Bricked Unit by Running out of Space?

Think I might have bricked a unit by running out of space.

I had a script running and I had a log file (not in /tmp unfortunately) that only was catching errors. I left it running overnight and somehow the filesystem ran up to 100% usage in non-volatile storage.

I didn’t catch it right away and issued a reboot command.

Now I cannot SSH in.
I can get in through the modem (com ) port to issue AT commands.

I had enabled factory reset button several weeks ago, but when I try to issue that command or the check status of factory reset button, I just get ERROR.

I have tried holding in the factory reset button on power up at least 5X and it doesn’t change anything.

When I try:

I also tried to re-install the firmware, which actually works, but doesn’t actually clear any space off the device. I was hoping re-installing firmware would clean all the files out.

Anything else to try?

see if you can downgrade to R11 and then use swiflash with -r option for recovery mode to erase the userapp partition:

Log string: ERROR=Flash write failed: Package not compatible (0X86),STATUS=FAIL

Tried V11 both Verizon and ATT.

Should I try another version?

is that now you still cannot SSH to it?
Do you have UART port in your FX30?

What is the return of the following AT commands?


Product: FX30S(WP7702)
Revision: 40
Main: MDM9206 (000)
Radio: WTR2965
Power: PMD9607 (002)
Flash: H27S4G8F2EKPB4 512MB x8 (173/0/0) (2048 blocks of 64 pages/block 4096B page size)

!MAPUART: 14,0
(Setup for 485 on the com port)

It looks like the atIentercnd worked this time

Tried to SSH to → Connection Refused

Anyway I can clear some space from the AT prompt?
I have 2 or 3 apps I created, I can remove those if possible to make room for a login maybe?

if you have the UART port, you can set AT!MAPUART=16,1, and then after reboot, there will be linux console terminal in this UART port.
After that you can use the flash_eraseall command to erase the userapp partition.

Does that mean I need to connect over the DB9 with an Adapter or I can use the same microUSB cable and it will enable this port?

I don’t know, you need to try both

I was finally able to do a reset with

it took quite a few tries, but it finally did it.

Which then told me to reboot.

I rebooted, connected over serial and verified AT command worked, then I downloaded R15 firmware.

I rebooted and did a factory reset a few times to make sure everything was cleared out.

I can connect over serial modem (to the AT commands), but still CANNOT connect using IP address I did verify that the Ethernet adapter was working and had assigned the to the interface.

I can ping from the command prompt, so it is not a connectivity or ethernet address assignment problem.

Any ideas what may be blocking me?

did you try the UART port to have the linux console?

For the SSH on, you can capture wireshark log on host side to see why there is connection refuse.

No, I have not tried that yet since I got the unit to finally factory reset.
I am assuming that the UART will be a RS-232 connection?

I will try that in the morning along with the Wireshark on the primary interface.