Binding Error gcc.lkopt


#1

Platform: Linux x386;
Install C/C++ Eclipse;
Install Software: M2M studio;
Install Plug-ins: OpenAt and necessary components;

Build example: hello_world

I receive an error: ‘cannot open linker script file gcc.lkopt: No such file or directory’

That does not suffice??


#2

Do you have python installed on your Linux system? gcc.lkopt linker script is generated by a python script.
M2M Studio Windows edition embeds the python runtime, but not the Linux one.


#3

Installing Python 2.2,2.3,2.4; What version is necessary?

Can it is necessary what or a Python`s package?


#4

M2M Studio embeds Python 2.5.2, but 2.4 will be fine.


#5

Platform: Windows7 x386 (working on XP compatibility mode)
Installed Full M2M Studio 1.1.1
Build Version 1.1.1.200911160856-R3160

Build Example: Multitask Example

Error: c:\program files\sierrawireless\m2mstudio\tools\armelfgcc\4.0.1\bin…\lib\gcc\arm-elf\4.0.1…\arm-elf\bin\ld.exe: cannot open linker script file gcc.lkopt: No such file or directory

If M2M Windows Edition already embeds the python runtime…What am i missing?

Thanks!


#6

Potentially another issue related to Windows 7 support, even in XP compatibility mode.
Incoming 1.1.2 (before the end of this month) should fix the issue.


#7

I just moved from Windows XP to windows 7 (64bit). I am having the same issue, is there a fix for this out?

I am using the latest studio available on the website.

Any help would be very much appreciated.


#8

This linker script is normally automatically generated by DS.
It should appear in the output directory immediately after a clean.
Does the project compile correctly (no compilation error before the link step)?
I’m thinking about an issue around the dependency to the OS package…
The most efficient way to help you: please can you issue a technical report including the project source code?


#9

I received this error with every project I’ve tried, including the hello_world example. I have reinstalled the studio.

I have checked in the workspace directories and the gcc.lkopt files are there, yet I still get the error ‘cannot open linker script file gcc.lkopt: No such file or directory’ at the “problems” sections.

To keep things simple, I created a new project with no code. So just the 2 defines and the main_task function. I then tried to build the system and copied the report here:

Any ideas?
Everything is working fine on my old computer (running Windows XP).


#10

No ideas, but some clues:

  • Give a try by installing everything somewhere with no spaces and out of Program Files directory. Normally this shouldn’t be an issue (this is our main test configuration), but who knows?..
  • Give a try to edit the linker command line, to make point to an absolute location to find the gcc.lkopt file (copy it elsewhere (once generated) if necessary).