BC127 in USB Host mode and cannot switch back!

I wanted to try updating the FW via the USB interface. I enabled the USB host by running the following commands:

set usb_host=on

I then lost UART (which was expected) but I could never get anything with the USB interface to work, including sending commands to go back to UART. So now what? I tried installing the drivers according to the app note and was able to get Windows to detect my BC127 USB device as a “CSR BlueCore Bluetooth”, but none of the BlueSuite tools could connect. I tried using the USB Demo App, but again got a message saying that it couldn’t find a device.

Out of frustration, I uninstalled the driver and re-scanned for hardware. It found the USB connection as a generic HID device and HID-compliant consumer interface control. Then, suddenly, the USB Demo App software could connect! (At least, I got the “USB Connected” message instead of “No Device Found”) So, I tried sending a status command. It timed out and I got the ERROR response. I dont know if that was generated from the app itself, or if it was a response from the BC127. If it was from the BC127, then I achieved communication, I just do anything with it because everything I send (followed by the Enter key) results in a delayed ERROR response.

What can I do!!? :open_mouth:

***EDIT: I did achieve communication! I connected to the BC127 from my phone and got the responses of the various stacks being enabled. I just cant figure out how to send the commands!

Some information I forgot to mention, I am using Melody 5.7 RC14.

I tried to get tricky sending the commands without hitting the “Enter” key by writing it as HEX followed by a proper 0x0D (\r), then converting that to ASCII. I thought that perhaps the command was not getting terminated properly? I copied the converted text (including the hidden control character) and pasted it into the program. It showed the command and placed the cursor under it (like it recognized the \r) without me hitting enter, but I get the same result:

Welcome! This application allows you to send commands over USB to Melody
Type 'c' and press Enter to connect to the device
USB Connected

I saw this video https://www.youtube.com/watch?v=rV_SyOCAsrU, which shows someone at BlueCreation using an older version of this tool with ease. He was using Melody 5.7 RC4. I see in the app note for the USBDemoApp_v1.2 that the tool is designed “to send commands via USB to Melody 6 (or 5.8RC4 onwards).” Could it be that I need to be running an older version of the tool like the guy in the video for 5.7 RC14?

HELP! :frowning:

Well, after over 70 views and no replies over almost 2 weeks, I finally got my unit working again. I bought the CSR USB to SPI adapter from Digikey and flashed the firmware posted here:

After the firmware flashed and all the defaults were reset, I got UART back. However, my project code was not ready for the protocol difference between Melody 5 and Melody 6, so I tried downgrading back to Melody 5 RC14 (despide reading that a backwards move from 6 to 5 was not allowed) but it worked! With 5 RC14 back on the device, my project worked once again.

But seriously… A proprietary SPI interface requiring a $15 adapter? Seems pretty sketch.

I dont know why the USB host mode didnt work. Perhaps a driver issue? Who knows.