AT+WOPEN respons


#1

Hi,
I tried to erase my app from flash using AT+WOPEN. It worked when I use AT+WOPEN=4,

AT+WOPEN=4
OK

The problem is when I send AT+WOPEN=3

AT+WOPEN=3
+CME ERROR: 532

What went wrong? Is there any other solution to completely erase app from flash?


#2

AT+WOPEN=3 erases object memory (objects that you store using the Flash API). If the flash has already been erased using this command, you will receive the error that you did.

AT+WOPEN=4 on the other hand erases application flash memory (i.e the Open-AT application that you downloaded onto the module). Once you send this command, the application is completely removed.


#3

Thank tomridl,
I’m a newbie in openat stuff, so thank for informed me this little thing.
Best Regards.


#4

I did the same thing (WOPEN = 3 & WOPEN=4) and now I can’t get WIPCFG=1 to work (I get ERROR).
How can I restore the default settings?. I did installed the Hello World program and it runs. Also with AT+WOPEN=2
I get +WOPEN: 2,“AT v06.20”,“AT v06.30” but WIPCFG=1 keeps giving errors.

Thanks in advance

Jaime


#5

Hi,

First you need to download WIPSoft.dwl(you will find this inside the WIP folder, under the software suite installations) file on the modem, then issue AT+WOPEN=1, then try to issue AT+WIPCFG command.


#6

Thanks a lot Rex_alex, that did it.

Jaime