AT+CPOF=1 problem with SL6087


#1

In my device, SL6087 module is powered on by button, which connects ON/OFF pin to +Vbatt (as described in Customer Design Guidelines). To power Off my module I’m issuing AT+CPOF=1 unsolicited command or from internal module’s application or through UART1.
Firstly all worked OK. But after some count of power ON/OFF cycles, several SL6087 modules refused to power OFF normally. It looks like: after issuing AT+CPOF=1 command (ON/OFF pin is LOW) to module, it responds with OK, but instead of normally switching off itself, it freezes.
Also if now this modules are powering up after or pressing RESET key, or only connecting +Vbatt to module. So they can’t be powered off.
This happens with or without application in module. Also I’ve tried to reflash downloader and firmware (7.51).
It was tested with both ON/OFF pin floating or tied to ground.
Can anybody help with this?


#2

Hi,
What do you mean by after issuing AT+CPOF=1(ON/OFF pin low)it does not switches off normally but freezes.How do you confirm it?
NOT1 : After powering off module uisng AT+CPOF=1 with ON/OFF pin LOW,this cane be deactivated on only when the ON/OFF pin is HIGH(if pin is low,hard reset will not make module come out of power off mode).

Thanks.