Application not running Q2687H


#1

Hi everyone,

I need urgent help with a strange problem please. I had a development kit which had a Q2687G on it. I developed an application which worked perfectly on the chip. I then created a PCB which has a Q2687H on it. First thing I did was downloaded the R74a00_full_q2687h.dwl firmware to the device with DwlWin.

I downloaded my developed application to the Q2687H with no problem using the Developer Studio. But when I run the application with AT+WOPEN=1 all I get is OK and +WIND: 0. No traces or nothing. The application state is displayed as running, but it does not look like its actually running the application.

Can anybody think of anything?

Thank you in advance.


#2

Check memory sizes for Q2687G and Q2687H. And compilation memory size for your application.


#3

Thank you for the reply, I have downloaded the “Hello World” sample and the same result. No traces and it does not seem like the application is really running. The flash LED indicates that the device is connected to GSM which makes it even more odd.


#4

I’m not sure but if you update firmware to R74 from older OpenAT OS you should use DwlWin, not .dwl file. So reflash your module with DwlWin and try again.


#5

Tried the .wpk with DwlWin and still the same result. I managed to get the device to detect the SIM card, so now I get +WIND: 1 at least, but nothing else. The application still does not seem like its actually running. Get no traces or UART output from the Hello World sample or my own application.


#6

The Q2687h had really old firmware on it. Like version 4.31 if I remember correct. Could the direct migration to version 7.4 have an impact on this issue?


#7

Is your device working normally (WIND indications, SIM detect, Dial Up) without starting application? Did you actually compile your app for R74 (it is selected in project options)?


#8

Yes it seems to function normally without starting the app, I get only the +WIND: 1 (SIM detected). No other +WIND indications appear. I have not tested Dial-up.

The device seems to be connected to the GSM network as I get a RSSI of 24 when issuing AT+CSQ. I can send AT commands and receive the relevant responses. I did start a new project with the correct firmware (7.4) and for the Q2687 (in project properties). The “Hello World” sample was used and compiled. I downloaded the code to the Q2687 with no problem or errors.

But still no traces or “Hello World” output from the Q2687. Could it be that the correct bootloader is not on the device?


#9

…and again: what memory type specified in your project settings?
For Q2687H option 256K+ must be used. For Q2687G you can set 1M+.


#10

Sorry, 1MB+ is set. I assume this might be the problem? Will try to set it to 256K+ later today and see what happens.

Thanx victorjd


#11

Victorjd thank you!!! It works like a charm. You really saved me on this one.

Again, thank you!