ALMS Error: [HTTP] Couldn't resolve host name

I’m getting this error on an RV50 when trying to connect to ALMS. This modem is on a private Verizon APN. Is there a way to get this working?

Hi there, were you able to solve your problem ? Our devices are as well with VZW Private APN and traffic terminated in AWS VPC. I was told that i need to configure route 53 (DNS) in order to resolve ALMS server url, but it is not working for me.

Super late reply, but I recently encountered the above error across dozens of gateways in a our fleet.

I found the fix was to perform the following:

  1. Delete the device in ALMS
  2. Export a settings template from a known working gateway of the same make, model and firmware revision
  3. Upload this template to the trouble gateway(s)
  4. Re-register gateway in ALMS

If you need to force communication from the gateway to ALMS, toggle the ‘ALMS Protocol’ setting from Disabled to LWM2M, MSCI or both.

It may also be beneficial to edit the exported settings template XML file prior to uploading to the problem gateway; example: I removed the ALMS name attribute from our template so that each problem gateway maintained its original name.