Airlink RV50 - connecting to the Internet using usb connection


With the support from your talented engineer, we were able to connect to the internet from our Linux board through PPP connection, much appreciated.
Now we’re trying to maximize the data throughput by using the QMI interface ( via usb connection), can you please provide the guideline to install the drivers on Linux board as well as configurations required for the RV50 side?

We’re using Debian Linux 8.10 (jessie).

Thanks in advance!


Hi @PTran,
No drivers required when connecting it to Linux. Use a USB cable to connect directly to your computer for best throughput.
The AirLink gateway is equipped with a USB port that increases the methods by which you can send and receive data from a connected computer. You can set up the USB port to work as either a virtual Ethernet port or a virtual serial port, or you can disable it to prevent access by USB. Please refer to USB content in attachment for more details
4117313_AirLink RV50 Series Hardware User Guide_r5.pdf (1.6 MB) (Page 23) (From page #121)
Please share any concerns you have and help us tick Solution if your problem is solved


Thank you for your reply.
However, it’s not the one that can solve our problem as below:

  • We configured the USBNet for the RV50 to get better data throughput.
  • However, on the Linux board, we don’t see the network interface configured for that usb connection, the usb0 is the only available and which is a console connection and already used.
    How can we create a new network interface on Linux board for the connection to the RV50?



Hi @PTran,
Please verify below on your environment:

  1. By default, when you connect RV50 to Linux, the USBnet interface will be generated if USBnet was set up as screenshot

  1. Check in Linux terminate
    vm123@ubuntu:/dev$ dmesg

[ 5.925464] [drm] VRAM at 0xe8000000 size is 4096 kiB
[ 5.925465] [drm] MMIO at 0xfe000000 size is 256 kiB
[ 5.932294] [TTM] Zone kernel: Available graphics memory: 1002982 KiB
[ 5.932296] [TTM] Initializing pool allocator
[ 5.932475] [TTM] Initializing DMA pool allocator
[ 5.932548] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 5.932549] [drm] No driver support for vblank timestamp query.
[ 5.932733] [drm] Screen Target Display device initialized
[ 5.932920] [drm] width 640
[ 5.932925] [drm] height 480
[ 5.932929] [drm] bpp 32
[ 5.934844] [drm] Fifo max 0x00040000 min 0x00001000 cap 0x0000077f
[ 5.940713] [drm] Using command buffers with DMA pool.
[ 5.940788] [drm] DX: yes.
[ 5.940789] [drm] Atomic: yes.
[ 5.940789] [drm] SM4_1: yes.
[ 5.948558] fbcon: svgadrmfb (fb0) is primary device
[ 5.949957] Console: switching to colour frame buffer device 100x37
[ 5.965822] [drm] Initialized vmwgfx 2.15.0 20180704 for 0000:00:0f.0 on minor 0
[ 6.861438] usbcore: registered new interface driver cdc_ether
[ 7.225619] rndis_host 1-1:2.0 usb0: register ‘rndis_host’ at usb-0000:02:03.0-1, RNDIS device, 62:6d:e8:81:12:e0
[ 7.229628] usbcore: registered new interface driver rndis_host
[ 8.278922] RAPL PMU: API unit is 2^-32 Joules, 0 fixed counters, 10737418240 ms ovfl timer
[ 8.368336] cryptd: max_cpu_qlen set to 1000
[ 8.469027] AVX2 version of gcm_enc/dec engaged.
[ 8.469028] AES CTR mode by8 optimization enabled
[ 9.518456] rndis_host 1-1:2.0 ens35u1c2: renamed from usb0
[ 11.036707] e1000: ens33 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[ 11.059258] IPv6: ADDRCONF(NETDEV_CHANGE): ens33: link becomes ready
[ 12.579182] NET: Registered protocol family 40
[ 46.033989] rfkill: input handler disabled

The USB inferface is renamed to ens35u1c2. Then let check it as

vm123@ubuntu:/dev$ ifconfig

ens33: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::19f1:b265:68f0:c26f prefixlen 64 scopeid 0x20
ether 00:0c:29:c4:47:04 txqueuelen 1000 (Ethernet)
RX packets 89 bytes 15382 (15.3 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 431 bytes 43221 (43.2 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

ens35u1c2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::54c3:bdfd:90b9:6647 prefixlen 64 scopeid 0x20
ether 8a:08:10:f5:15:68 txqueuelen 1000 (Ethernet)
RX packets 1554 bytes 1065418 (1.0 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1695 bytes 254801 (254.8 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 386 bytes 39147 (39.1 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 386 bytes 39147 (39.1 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

  1. Configure the cellular for RV50 by inserting APN as screenshot. Then your linux is able to connect internet

    I am practicing on Ubuntu but Debian Linux is same I beleive. If the problem still exists please share the steps and screenshots you did as above
1 Like