Airlink GX450 (ALEOS Version 4.9.6) not sending location data when using FQDN

We are using GX450 modems on ALEOS Version 4.9.6 in our fleet. Currently we are sending location reports to an IP address, which has works for years but we need to migrate to using a FQDN. When we change the Report Server 1 IP Address from IP to FQDN (Example:, the modem stops sending location data. I have confirmed this is the case on several modems of the same version and firmware. I also confirmed that if I go to Admin->Advanced->Ping and ping this FDQN, the modem properly resolves to the correct IP address.

I set the Events Reporting/Location log to debug and can see in the log where it resolves the proper address but doesn’t seem to send the location data. This is likely a bug but wanted to see if anyone else is experiencing this. Thanks for all the help!

Hi networktech7,

As I know, this issue was fixed on FW 4.9.0. Could you please double-check if there was any space before or after your FQDN?


We applied the change via an Airvantage console template originally which seemed to push the change but we didn’t receive location updates on the server. Yesterday I configured the location server FQDN directly through the modems web console and confirmed we received location updates. I then tried another modem using the Airvantage console’s manual configuration not a template and that worked as well. When I return to my office next week I will check the Airvantage template to see if there is a space and test again. Thanks!

Hi jerdung,

I created a new Airvantage template to push the location server settings using the FQDN. After pushing the new template, the GX450s are now providing updates to the location server. I reviewed the original template to determine if there was a space before or after the FQDN and didn’t see one but the new template is indeed working. We should be good now. Thanks for the assistance.

After pushing the Report Server IP Address setting from the Airvantage Console to dozens of GX450 (V 4.9.6) using an FQDN, I have found that most units report their location properly but several do not. I have found that the modems that do not report the location with the FQDN will work if I change them back to an IP destination. I have also had a few that after changing the modem to use an IP and then back to an FQDN they will report correctly. I have yet to lock down a pattern of why some work and some don’t and have confirmed they have the same configuration. It is starting to seem like a possible bug. Any suggestions would be appreciated. Thanks again.