Airlink GX440 firmware upgrade issues

I’m trying to upgrade my GX440 but every time I try I get the APPLYING FIRMWARE stage and get the following error message “Unpacking firmware bundle failed”. I’m currently running firmware version I realize I’m a few upgrades behind and need to update incrementally, so I tried using the Upgrade Shortcut Build since I’m running on a Verizon network. It’s supposed to work on older versions but I still get the same failure message. I have unzipped the files but that doesn’t work either. Anyone else have this issue?

Any more info on this?
I have a GX440 doing something similar.
It is running 4.3.6 but I get this “Unpacking firmware bundle failed. Please try again.” error whenever I load a new firmware into it.
I have tried 4.4.0, 4.4.1, 4.4.4, and even resending 4.3.6 to it.

I have upgraded hundreds on similar modems, but this one is bothering me.

It seems like something needs to be cleared in the OS.
But I do not know if there is a way to do that outside a factory reset.

The “Unpacking firmware bundle failed” could related to not enough available space or file system corruption. You may need to contact the reseller where the unit was purchased from and ask to RMA the unit.