7355 unrecognized WWAN but GPS showing

So i’ve used the search function as much as i can to find a like issue.

To start-
Windows 10 2h22
Panasonic Toughbook CF-54 (G)
Panasonic Toughbook CF-54 MK2 Sierra Wireless EM7355 GPS Kit Blox NEO-M8N-0-10 Module

I have it plugged in. (3 ant pins to M.2 Card)

Sierra Wireless EM7355

Supported model(s):
CF-19 / CF-31 / CF-53 / CF-54 / CF-C2 / FZ-G1 / FZ-M1
Supported OS: Windows 7, Windows 8, Windows 8.1 and Windows 10
Supported Network(s): 4G

Downloaded and installed the red icon exe. (not the .bats)

Device manager shows it under GPS module.
However it does not show up under WWAN.

The SIM is active, tied to the IMEI on the the card and is active. (Verizon)

Did command Netsh. Actived auto on services for WWAN.

Tried to check WWAN on command and it says “Not Available”

What did i mess up or could i have a dead card?
OR do i need the GPS antenna for both cellular and GPS?

Is there any modem port in device manager?

Yes it shows up there.

I figured it out with about 12 hours into deep google/bing (yes i went that far)

So apparently on the CF-54 there is a BIOS setting you have to change to get the LTE system to operate openly. Unlocked that and bam. Solved the problem.