WP85 Voice Call


I have been fiddling around with voice calls on my WP8548.
Unfortunately, I got only as far as unlocking my (non-M2M) SIM and registering to the network:
(See SIM / Network info below)

At the callback: LE_CELLNET_REG_HOME, (in response of le_cellnet_Request())
I tried setting up a voice call via the le_mcc_interface.h as in the sample
which failed, as well as via the le_voicecall_interface.h

Both returned similar results:

Note I call le_voicecall_start( ). As I would not know what else the DestinationID could be.

I have no clue, how a connection could already have started, as the returned ‘LE_VOICECALL_EVENT_RESOURCE_BUSY’ suggests.

Calling “ATD;” also failed: ‘NO CARRIER’

SIM / Network info

[code]> cm info
Device: WP8548
IMEI: 359377060008421
FSN: LL542500190503
Firmware: SWI9X15Y_07.08.02.00 r31088 CARMD-EV-FRMWR1 2016/02/05 23:29:29
Bootloader: SWI9X15Y_07.08.02.00 r31088 CARMD-EV-FRMWR1 2016/02/05 23:29:29

cm radio
Current Network Operator: Proximus
Status: Registered, home network (LE_MRC_REG_HOME)
Signal: Strong signal strength (4)

cm sim
SIM card is inserted and unlocked (LE_SIM_READY).

cm sim info
ICCID: 8932002100248530091
Home Network Operator: Proximus
IMSI: 206012224731281
Phone Number:

Just upgraded from 16.0.beta to 16.1.2
Unfortunately it did not resolve this issue

This might explain my issues:
From Firmware customer release notes:

5.3 Known Issues

ID      |Title                   | Description                                   | Impacted domain
Various | Audio is not supported | Audio is not supported in this release.       | Audio
        |                        | Voice call control functionality is disabled. |
        |                        | The USB audio interface is exposed by default.|


I tried downgrading to release SWI9X15Y 7.0 Release 7, in which the old audio code still works.
SUCCESS! :smiley:

> ATS0=1   //set automatic answering after 1 'RING'

/*Called the SIM phone number...*/
> RING       //incoming call
/*Automatic pick up of phone call!!*/

I could only downgrade a module with PRI Part Number: 9904889
But I need to test voice call on a module with PRI Part Number: 9905383
=> possible solution: try downgrading to SWI9X15Y 7.0 Release 8.
=> Unfortunately, these download links are down:

  1. Carrier Configurations:
  2. Legato:

Any alternative download links for these?


Audio is supported as of SWI9x15Y_07.10.04.00, Release 11. You may upgrade to this version and try again.