WP7606 data connect

Hi everyone,

I’ve been trying to run cm data connect but this is what happens:

root@swi-mdm9x28-wp:~# cm data connect
Setting up profile 1
Connecting ... ok
Checking if device 'rmnet_data0' is up ... ok
Routing inet ... ok
mv: can't remove '/etc/resolv.conf': Device or resource busy
Routing inet6 ... ok
mv: can't remove '/etc/resolv.conf': Device or resource busy
Testing connection ... ok

After that I try to ping mangoh.io but not a single packet is received:

root@swi-mdm9x28-wp:~# ping mangoh.io
PING mangoh.io (35.184.189.106): 56 data bytes
^C
--- mangoh.io ping statistics ---
9 packets transmitted, 0 packets received, 100% packet loss

Do you know what’s going on?

How about ping 8.8.8.8 ?
How about ping www.google.com?
How about shut down the firewall of the module?

iptables -I INPUT -j ACCEPT

With these two addresses it’s basically the same:

root@swi-mdm9x28-wp:~# cm data connect
Checking if device 'rmnet_data0' is up ... ok
Routing inet ... ok
mv: can't remove '/etc/resolv.conf': Device or resource busy
Routing inet6 ... ok
mv: can't remove '/etc/resolv.conf': Device or resource busy
Testing connection ... ok
root@swi-mdm9x28-wp:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
^C
--- 8.8.8.8 ping statistics ---
16 packets transmitted, 0 packets received, 100% packet loss
root@swi-mdm9x28-wp:~# ping www.google.com
PING www.google.com (172.217.19.68): 56 data bytes
^C
--- www.google.com ping statistics ---
10 packets transmitted, 0 packets received, 100% packet loss

How about shut down the firewall of the module?

iptables -I INPUT -j ACCEPT

I don’t know if I really want to disable the module’s firewall.
But if I wanted to, I would have to run the command when connected to the module, right?
So basically like this:

root@swi-mdm9x28-wp:~# iptables -I INPUT -j ACCEPT

And what about this? Might this be part of the problem as well?

mv: can't remove '/etc/resolv.conf': Device or resource busy

i don’t think that is a problem, please see my log:

root@swi-mdm9x28-wp:~# cm data connect &
root@swi-mdm9x28-wp:~#
root@swi-mdm9x28-wp:~# Setting up profile 1
Connecting … ok
Checking if device ‘rmnet_data0’ is up … ok
Routing inet … ok
mv: can’t remove ‘/etc/resolv.conf’: Device or resource busy
Testing connection …
root@swi-mdm9x28-wp:~#
root@swi-mdm9x28-wp:~#
root@swi-mdm9x28-wp:~#
root@swi-mdm9x28-wp:~# cm data
Index: 1
APN: hkcsl
PDP Type: IPV4V6
Connected: yes
Interface: rmnet_data0
Family[IPv4]: inet
IP[IPv4]: 10.183.67.45
Gateway[IPv4]: 10.183.67.46
Dns1[IPv4]: 10.144.148.1
Dns2[IPv4]: 10.145.148.5
root@swi-mdm9x28-wp:~#
root@swi-mdm9x28-wp:~# ping www.google.com
PING www.google.com (216.58.220.196): 56 data bytes
64 bytes from 216.58.220.196: seq=0 ttl=116 time=35.981 ms
64 bytes from 216.58.220.196: seq=1 ttl=116 time=59.675 ms
64 bytes from 216.58.220.196: seq=2 ttl=116 time=56.151 ms
^C
www.google.com ping statistics —
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 35.981/50.602/59.675 ms

I just tried to replicate your steps but it’s not working.

root@swi-mdm9x28-wp:~# cm data connect &
root@swi-mdm9x28-wp:~# Checking if device 'rmnet_data0' is up ... ok
Routing inet ... ok
mv: can't remove '/etc/resolv.conf': Device or resource busy
Routing inet6 ... ok
mv: can't remove '/etc/resolv.conf': Device or resource busy
Testing connection ... ok

[1]+  Done                       cm data connect
root@swi-mdm9x28-wp:~# Setting up profile 1
-sh: Setting: not found
root@swi-mdm9x28-wp:~# cm data
Index:                         1
APN:                           internet.telekom
PDP Type:                      IPV4V6
Connected:                     yes
Auth type:                     PAP
Interface:                     rmnet_data0
Family[IPv4]:                  inet
IP[IPv4]:                      10.26.102.145
Gateway[IPv4]:                 10.26.102.146
Dns1[IPv4]:                    10.74.210.210
Dns2[IPv4]:                    10.74.210.211
Family[IPv6]:                  inet6
IP[IPv6]:                      2a01:598:9182:d005:608d:bbb5:3385:b3e0
Gateway[IPv6]:                 2a01:598:9182:d005:c4ea:9ab9:551f:839
Dns1[IPv6]:                    2a01:598:7ff:0:10:74:210:210
Dns2[IPv6]:                    2a01:598:7ff:0:10:74:210:211
root@swi-mdm9x28-wp:~# ping www.google.com
PING www.google.com (172.217.17.100): 56 data bytes
^C
--- www.google.com ping statistics ---
18 packets transmitted, 0 packets received, 100% packet loss

Regarding my last question, is this the correct way to disable the firewall:

root@swi-mdm9x28-wp:~# iptables -I INPUT -j ACCEPT

How would I enable it again?

you need to setup the iptables to enable the firewall again.
But I think the firewall will be automatically restored once you reset the module.