WP7504 - No Audio Over Voice Call


#1

Hi everyone,

I’m having an issue with audio transmission during a voice call. When placing a call to my phone, I the device does not appear to send or receive any audio. I’m using a WP7504 module in a mangOH Red board. I am using the Legato platform.

I do not appear to have any issues connecting to the network (signal is very strong and device is registered). Also, I can use data services with no issues.

What I’ve tried:

  • I have verified that the volume is up and unmuted via the AT commands “AT+CLVL” and “AT+CMUT”.
  • I have tried calling directly via the AT command “ATDxxxxxxxxxx;”.
  • I have tried two different networks, both AT&T and T-Mobile. I am using RedPocket as my carrier.
  • I have tried setting the RAT to both “UMTS” and “LTE”.
  • An associate suggested it may be an issue with the PCM audio codec and the device’s clock; I have attempted setting “at+wextclk” to “1,0” and rebooting, although it seems to have no effect.
  • I have tried using both of the Legato calling APIs (“Modem Call Control” and “Voice Call Service”) in my code.

Details:

  • Board: mangOH Red
  • Module: WP7504
  • Firmware version: .12.14.00 r34472 CARMD-EV-FRMWR1 2017/11/29 18:24:42
  • Legato version: 18.05.1_17ce41dbc4af6057ebf5fd9215b38e2

I am at a bit of a loss. Any info on what I should investigate would be seriously appreciated. Please let me know if I should provide any additional information. Thank you much in advance.