WISMO 228 and ATD command


#1

Hello everybody,
this is my first message on this forum.
I explain my problem.
I’m using WISMO228 , and using different type of sim card I see different behavior during ATD command.

Simcard type 1 Wismo works well.
Simcard type 2(microsim like IPhone) the calling is not done, exactly the receiver number doesn’t see RING. It seems that the command is not executed.

For every test I’m sure that the module was registered at home network (CGREG command)
I tested these 2 types of simcard in GPRS (TCP socket)and wismo works well with every sim.

I performed others tests using same simcards on Fastrack module and on my board with Q2400A
In every test fastrack and Q2400A works well.

Another test is the following:
Same application firmware(my firmware) different hardware(the 2 release are compatible the only difference is that 1st board Q24A00 and 2nd board with WISMO228).
I tried to use the 2 types of sim and the problem was present only on WISMO 228 with microsim.
In every test the board was register at home network.
I tried to read from sim card and it runs well.

I tested 2 version of firmware of wismo ATI3 command:
L10_00gg.WISMO228 031109
L22_00gg.WISMO228 281210

Can you help me?
Bye
Riccardo


#2

Hello, news:
I upgrade WISMO228 to versione L23a and the problem persists.

Can you help me?

Bye
Riccardo


#3

Hi Riccardo,

I am guessing if there are STK feature on that particular SIM.
Please check “AT*PSSTKI?” command.

L