Wipsoft HTTP Client sample dosen't work on Q2687H


#1

Hi.

I’m working with Sierra Wireless Q2687H GPRS modem. I would like send some measurement data through GPRS bearer using HTTP protocol.(This would be my finale goal.)
I thing the easiest way would be if I could use at commands. In order for that I installed the WipSoft TCP/IP plugin.
First of all I tried the ping sample and everything went well. After that I want send some HTTP request, so I tried use http client sample I found in the wip at commands user guide (Wifpsoft V3.11). But I’m unable to connect…

The command I use are as follows (I use Firmware 7.44 with Wipsoft 5.40 plugin)

AT+WIPCFG=1 // start IP stack

OK

AT+WIPBR=1,6 // open GPRS bearer

OK

AT+WIPBR=2,6,11, “APN name” // set APN name of GPRS bearer (in my case APN name = vitamax.snet.vodafone.net)

OK

AT+WIPBR=2,6,0, “user name” // in my case it`s omitted, because I don’t have it

OK

AT+WIPBR=2,6,1, “passwd” // in my case it`s omitted, because I don’t have it

OK

AT+WIPBR=4,6,0 // start GPRS bearer

OK

AT+WIPCREATE=5,1,“http://www.google.com”,80,"",""

OK

+WIPREADY: 5,1 // so far it’s seems to be working everything fine

AT+WIPFILE=5,1,1, “http://www.google.com/index.html","","

But after this command line I don’t get any answer.
I mean,I don’t get either any error code or any other unsolicited answer from the modem. As far as I know if everthing went well, I would get “CONNECT” unsolicited answer, wouldn’t I? But unfortunately nothing happening:(

Please, if anyone know what would be the problem pleas help me!

Thanks and Best Regards

Szilard


#2

Hi
Yes if everything is correct you should receive a CONNECT after AT+WIPFILE.May be there is some problem in the url you are providing.I guess since there is no username and password you providing you can do without the “”.Further try with just this url google.com