WIP_COPT_RESTART not working. WHY?


#1

I try use option “WIP_COPT_RESTART” in function wip_putFileOpts:

dst_data = wip_putFileOpts( dst_ftp_cx, DST_FILENAME, evh_data, NULL,
WIP_COPT_RESTART, DataOffset,
WIP_COPT_END);

File DST_FILENAME not saved to ftp server.

Log from FTP server:
FTP REST 98
FTP QUIT

WHY not working command STOR ??
Sorry for my english.


#2

Module Q2687h.

In active FTP: :slight_smile:

[FTP=>] "220 Titan FTP Server 6.24.621 Ready."
[FTP<=] USER propet
[FTP=>] "331 User name okay, need password."
[FTP<=] PASS 21281
[FTP=>] "230 User logged in, proceed."
[FTP<=] TYPE I
[FTP=>] "200 Type set to I."
[WIP] new TCPSERVER 0x180c4898
[FTP<=] PORT 172,24,30,96,4,1
[FTP=>] "200 PORT command successful."
[FTP<=] REST 1000
[FTP=>] "350 Restarting at 1000 - Send STORe or RETRieve to initiate transfer."
[FTP<=] STOR data.txt
[FTP=>] "150 File status okay; about to open data connection."
[WIP] new spawned TCPCLIENT 0x180c49b8
[FTP<=] QUIT
[WIP] closing CHANNEL 0x180c4898
[WIP] closing TCPCLIENT 0x180c49b8
[WIP] closing WRAPPER 0x180c4978
[WIP] closing TCPCLIENT 0x180c2978
[WIP] closing FTP_CONTROL 0x180c44d8

In passive FTP: :smiling_imp:

[FTP=>] "220 CommuniGate Pro FTP Server 5.1.1 ready"
[FTP<=] USER upload
[FTP=>] "331 please send the PASS"
[FTP<=] PASS lj
[FTP=>] "230 welcome"
[FTP<=] TYPE I
[FTP=>] "200 type set to IMAGE"
[FTP<=] PASV
[FTP=>] "227 Entering Passive Mode (217,23,185,155,234,96)"
[WIP] new TCPCLIENT 0x180c48d8
[FTP<=] REST 1000
[FTP<=] QUIT
[WIP] closing TCPCLIENT 0x180c48d8
[WIP] closing WRAPPER 0x180c4678
[WIP] closing TCPCLIENT 0x180c2eb8
[WIP] closing FTP_CONTROL 0x180c44d8