Anybody sucseed with WIP FTP?


#1

Hello!
I’m trying to connect FTP server using Q2686H with WIP 2.00.15.
FTP server is passive, so SRC_ISPASSIVE = FALSE, connection is not anonymus.
I opened gprs bearer, all OK, then i’m trying to create FTP connection using this code, but always recive FTP ERROR:

wip_channel_t ftp_WipHandle;
    ....................................
    ftp_WipHandle = wip_FTPCreateOpts (
    SRC_SERVER,  ftp_SessionHandler,  NULL,
    WIP_COPT_USER,     SRC_USER,
    WIP_COPT_PASSWORD, SRC_PASSWORD,
    WIP_COPT_PASSIVE,  SRC_ISPASSIVE,
    WIP_COPT_END);

  if( ! ftp_WipHandle) 
	{	
	   adl_atSendResponse(ADL_AT_RSP, "\r\nFTP ERROR\r\n");
	}
	else
		adl_atSendResponse(ADL_AT_RSP, "\r\nFTP STARTED OK\r\n");

Can anybody tell me what is wrong!


#2

Surely, if the server is passive, then SRC_[color=red]ISPASSIVE should be TRUE, shouldn’t it?! :open_mouth:


#3

It’s my error in this listing. In program ISPASSIVE is TRUE :slight_smile: but nothing works! Did anybody sucsseed with WIP FTP functions?


#4

I also have problems with retrieving a file with ftp in both passive and active mode. It looks like the second connection (where the data is transmitted) won’t get established.


#5

Is the Internet Plug In activated in the module? If not, the ftp api doesn’t work. Check with the AT+WCFM=5 at command!

tom


#6

AT+WCFM=5 returnes:
+WCFM: 00000000,0, so internet PlugIn seems to be disabled. And how can i enabel this PlugIn? And why wip_TCPClientCreate command creates TCP Socket hanle and wip_FTPCreate retuenes NULL?


#7

+WCFM: 00000000,0 means it is with TCP/IP plugin enabled, but not Internet Plugin enabled. So for TCP/UDP it is supported but not higer level protocol (FTP,email…)

Contact your distributor for Internet Plugin enabled products


#8

I’m running C61b09gg.Q2687H

Testing +WIPFILE, if the specified filename was wrong, or the file didn’t exist on the server. It would CONNECT anyways and then eventually timeout with two errors 841 and one 839, peer closed and error during channel creation. After that a WIPCLOSE just give bad state and I had to reset.

Worked fine though when I got the filename right.

I look at the list of possible +CMEE errors for +WIPFILE
and I don’t see anything resembling “file not found”.
Could be an issue if whats on the ftp server doesn’t match the specified filename.

I also didn’t see anything in the WIP AT command documentation about setting passive ftp mode. Is it possible to set passive mode ftp using AT commands?


#9

We recived new party of Q2686H modules from our distributor with enabled Internet PlugIn. Problem solved. Thank’s!


#10

Hi all
I work with the same module but using the WIP sample FTP. I used it in targer mode and applied at+ wipftp from hyper terminal to get the file from the server. It works fine no errors but i need to know where the file is stored in the module and how can I access it.
You look like a group of FTP file transfer experts can anyone help me hereI am a beginner…