FTP with WIP


#1

Anybody tryed to connect FTP server using WIP library?
I created TCP Client Socket on 21 port of the server, recived server greeting and then i’m trying to register using:

wip_write( c,"USER gprs", strlen("USER gprs"));

And… nothing! I don’t see anything in server logs. Am I doing something wrong? How can I send command strings to the FTP server?


#2

Hi Amat
FTP is not yet implimented in WIP
I was told that it should be ready in November
Best regards
Walter


#3

I know, that FTP is not ready. That’s why I’m trying to do it myself using TCP socket connection.


#4

Haven’t used FTP, but basically it should work. I tried HTTP with
connecting to “209.173.53.180”, Port 80

wip_write(i_pTcpSocket->aSocket,"GET /rfc.html HTTP/1.1\r\n",24);
	wip_write(i_pTcpSocket->aSocket,"Host: www.ietf.org\r\n\r\n",22);

which works fine.

Have you tried what you do with telnet before? There you can experiment with the protocol.

You may need a linefeed (\r\n)

cheers
Philipp


#5

Thanks, Philipp! Of course it was a linefeed!


#6

Thanks, Philipp! Of course it was a linefeed!