Valid 10 digit mobile number


#1

Using the RV50x I’m trying to send an SMS without putting a “1” on the front of my 10 digit phone number. For some reason it is continually being rejected with the message

########## Error Invalid Number. Please re-send using a valid 10 digit mobile number or valid short code. THIS IS A TEST

However as soon as I put a 1 on the front it sends with no problems. Except randomly it will accept the 10 digit number without the 1. Can anyone tell me how I can get this device to work in a stable manner without having to put a 1 on the front of my numbers? In the application I’m doing the phone numbers are being taken from Active Directory and I don’t want to have to worry about someone editing the contact number to remove what should be an unnecessary 1 and breaking everything!


#2

Can anyone tell me where I can actually get support for Sierra products? Every distributor I’ve called on their “Contact support” page doesn’t know anything about this product and their help documentation says “you shouldn’t ever have to change this setting” rather than telling me what the setting actually does!

Some people in other forums have suggested that there should be a setting somewhere to specify how the phone number should look and/or whether or not to auto-append a “1” to the front of the phone number, but I cannot find any setting like this in the manual. Is anyone else receiving this kind of error?