Using fx30, internet router

Hello ALL.

Using fx30, internet connection is OK, just itself, but I don’t know how can I set up router.

I want to beaglebone black connect internet using fx30 with RJ45 wired cable or usb modem.

You can share the data connection with USB ECM interface:

Fx30 side:

echo > /etc/resolv.conf
cm data connect &
iptables --flush
iptables -t nat -A POSTROUTING --out-interface rmnet0 -j MASQUERADE
iptables -A FORWARD -o usb0 -i rmnet0 -m state --state RELATED,ESTABLISHED -j ACCEPT
iptables -A FORWARD -i usb0 -o rmnet0 -j ACCEPT
echo 1 > /proc/sys/net/ipv4/ip_forward
cat /etc/resolv.conf
nameserver 10.144.148.1
nameserver 10.145.148.5


PC side:

sudo route add default gw 192.168.2.2 usb0
sudo echo -e “nameserver 10.144.148.1\nnameserver 10.145.148.5” | sudo tee /etc/resolv.conf
ping www.google.com

1 Like

Thank you so much!

It’s working !!

one more question
manual setup is OK.
but I want when power on, internet connect by automatically.

PC side setup is easy, but fx30 is difficult for me(new user).

you can modify the init script /etc/init.d/startlegato.sh

if you have a router then you should connect the router with the wan port in the back and then port a lan wair to the pc facebookthen o to the router ip address and set up the ip configaration tehn you go to the pc netwarking and shering center go to the new netwark select home thn go to the network configaration protocon ipv4 set up obtain ip automatically then save it. Now you can connect the internet working

Setting up of router is not a difficult job. Even I have set my own router by my own. You can look for the steps in this facebook page. It is really helpful.I will suggest you to connect the internet with USB Modem.

fx30 is a very good router I have been using this from the past couple of years. The internet connection with it is very good and setting up is also fairly easy. I saw on a facebook group that this router is very good that’s why I brought it.

I was trying to set up the router, but when I entered the default IP 192.168.254.254, it couldn’t be accessed. What should I do?

Hi aalis,
After you change FX30 to IP 192.168.254.254, please make sure that your PC’IP is the same subnet with FX30.
Beside that, you can connect to FX30 via USB, and ssh to default IP 192.168.2.2 via ecm interface.

Thanks,

1 Like