Using external interrupt + WIND12 indication under W32K mode


#1

Module: Q2406A
Firmware: x44 Beta
OpenAT: 2.12
Hardware: Custom

When W32K mode is disabled the module reliably responds to
the external interrupt line by sending the WIND12 indication.

However, when W32K mode is activated and the module has
entered low power mode it does not respond to the external
interrupt.

The same happens when the openat application is disabled.

Is anyone using the external interrupt line, and can anyone confirm
this behaviour?

Regards,
Nic


#2

Hi Nic,

I use also the external interrupt. But I can receive “+WIND: 12” in both modes (with an without w32k).

Is the interrupt feature activated in your wavecom management (wfm)?

If yes, I think there is a problem with the x.44 Firmware.
I use x.40 and x.41 firmware and I have no problems with it.

regards,
skos


#3

Hi,

Thanks for the response.

AT+WFM=2 gives:
+WFM: “INTERRUPT”,1,0

I have just tried version 541b09gg, and the problem remains. Behaviour
is the same with and without OpenAT.

Which module do you use?

For how long do you pull the interrupt line low? Is it a pulse, or do you
keep it asserted until the Wismo responds?

I have changed the external uC to keep the interrupt low until the Wismo
responds (by doing an I2C read). This seems to work, but I will have to
wire up a logic analizer to check if the Wismo is actually responding to
the interrupt, or if it is only seeing and reporting it when it wakes up for a
different reason.

On your application, do you monitor CTS to check if the wismo is in sleep
mode? How often does it wake up (pulse CTS on/off)?

Best regards,
Nic


#4

Hi Nic,

This is ok.

I use Q2400A and Q2406B modules with OpenAt 2.0 and OpenAt 2.10c.

I use a pulse with roundabout 30ms to low level to receive the WIND indikation.

No, I don’t monitor CTS.

Perhalps the direct coupling from the uC and the IRQ-pin could be the problem. I use an open collector transistor and no additional external pull up resistor to switch this IRQ-pin.
I hope you can find the problem, because in my applications I have no problems with this pin.

Best regards,
skos


#5

Perhalps the direct coupling from the uC and the IRQ-pin could be the >problem. I use an open collector transistor and no additional external >pull up resistor to switch this IRQ-pin.

The external uC is an AVR, and I’m using the IO pin as an open collector
driver. The output is never driven high. When not asserted it is configured
as an input without a pullup, and when asserted it is an output driving
low.

The problem was caused by the uC not asserting the interrupt line
for long enough.

When W32K=0 the interrupt latency is 3-4mS, and the Wismo will
respond to a pulse a few uS long.

When W32K=1 the interrupt latency is 7-8mS, and the interupt line
needs to be asserted for a few milliseconds.

I have changed the uC code to keep the interrupt asserted until the
Wismo responds, and so far this has worked perfectly.

Regards,
Nic.


#6

Is there any ADL command to handle “External Interruption”?

Thanks

Henrique


#7

Hi,

I have never used ADL, but since ADL is simply a layer on top of
OpenAT it must be possible.

Under OpenAT you enable the indication using AT+WIND=2559,
and then you will get a +WIND: 12 message when the interrupt
is triggered.

Regards,
Nic