User flash erased during normal operation! Bug?


#1

Hi everybody,

we have a very strange problem. We designed an emergency cell phone and the hardware is already in use for quite a while without having seen problems of this kind before:

A customer in Austria managed to crash two of the phones the same way: It looks like the flash memory has been completely erased!!! Our application code uses basic OpenAT API (not ADL!) still in version 2.0 and does not contain any calls to functions that could erase the whole flash memory!

The core firmware in the device is:

ati3

640d09gg.Q2406B 1273604 091103 18:26

OK

How could the user flash even be erased? (It appeared like sending AT+WOPEN=3 - the application flash did not seem to be affected, after restoring configuration in user flash memory the application worked fine again…) I can’t imagine a scenario that would kill the flash contents just like that… Even if a watchdog would have kicked in, there wouldn’t be the memory contents erased, would it? Our application has been developped over several years already and is pretty stable! Crashes like that we haven’t seen so far!

Has anybody else experienced an unexplainable loss of user flash memory contents?

Thanks in advance,
Jan


#2

Hi Jan,
I have also never seen such kind of problem in which the complete flash data is erased. Did you get some ARM exception or RTK exception in this case? Probably, this might help you find out the cause of the problem.

The module must have performed some invalid operation which might have corrupted the internal flash area (the area where the location of flash objects are stored) and this might have performed the damage.

However, I am not sure of this as to what might had happened as I have never experienced such problems.
Has anybody in the forum, experienced such problems? If yes, please share your experiences.

Best Regards,
Open AT Fan.


#3

Thanks for your answer, Open AT Fan!

I can’t tell if an exception happened, since the customer did not have the possibility to log debug output…

I tried about 30 times to reproduce the problem at work (here in Germany) by doing what the customer had done - nothing happened, everything worked just fine. So I am still clueless… But we’ll try to reproduce it with debug features turned on at the customer’s site. I hope we can find the problem, and if we can, I’ll post it here…

Best Regards,
Jan


#4

Hello folks,

There are out appr. 300 q2406 module in a product with firmware 6.41.
From that i see sometimes “dead modules” and after reflashing it working fine. Our testers say that with firmware 6.50 this problem has not occured yet. That product don’t use Open AT, and i have no idea what is the origin of the problem.

tom