URGENT, simple GPIO problem


#1

Hello,

We bought a dozen of Q64 (001) modules, everything seems to work but the GPIO. we are having a really hard time trying to output or input any data or logic levels. The same code is tested and working on a WMP100 development board…

The firmware is 7.1.we do not get any error during compilation, nor during function subscription, nor during runtime. The only symptom is that the inputs always read as ‘0’ and all output are floating, and drop to 0.6 when connected to any load, even trying to drive the base of a resistance with a 10Kohm resistor.

We’ve tried to add pull ups, pull down, we tried various modules, nothing helps… the GPIOs seems to be totally disconnected what can be the problem?

did anyone experience a similar problem?

is there any known bug about that?

thanks


#2

hi Ikalog,

you´re application must subscribe to GPIO of WMP100. See doc. “Q64_Software_User_Guide_-_003.pdf”, pag. 11.
The GPIO of Q64 must subscribe as :

Q64 ==> WMP100 (subscribe this one)
GPIO01 ==> GPIO19
GPIO02 ==> GPIO20
GPIO03 ==> GPIO21
GPIO04 ==> GPIO22

and so…

Hegler


#3

Could you tell me the price of Q64 and what time support FTP protocol?

Kind Regards,

wavehlmao


#4

Could you tell me the pricr of Q64 and when will it support the FTP?

kind Regards,

wavehlmao


#5

Only a Distributor could answer that for you!

And they almost certainly wouldn’t do it in a public forum!


#6

Now q64 support the ftp but the fireware will be R71 upwards