Upgrade to Firmware 7.4a and UART2


#1

Hi,

I connect a device to the UART2 at 38400 baud:

Using the adl_atCmdCreate function, I do:

// Check if already open
AT+WMFM=0,2,2 [OK]
// Open it (if not)
AT+WMFM=0,1,2 [OK]
// Set baudrate
AT+IPR=38400 [OK]
// Set character framing (8 data 1 stop)
AT+ICF=3 [OK]
// Set flow control (DCE_by_DTE=none DTE_by_DCE=none)
AT+IFC=0,0 [OK]

And then switch to data mode ( adl_fcmSwitchV24State (myUartHandle, ADL_FCM_V24_STATE_DATA); ) to start communication.

All work fine !

But since I upgrade the firmware from R74 to R74a the device does NOT answer ! If I downgrade to R74 all re work fine.

NOTE: The connected device works ONLY if CTS signal is kept high all the time. But according to the doc “When <DTE_by_DCE> parameter is set to 0 (none), the CTS is kept high all the time”.

Is any reason that R7.4a does no more do that ?

Does anybody have an idea of a such behavior ?

Thanks’


#2

Hi,

I confirm that the R7.4a does NO more keept the CTS signal high with AT+IFC=0,0 !

Why ?


#3

Hi,

Is the right place for this post ?

Moderator can you move it please in the correct section ?

Thanks’


#4

did you raise an issue with your distributor?
they can get wavecom to notice this.

this forum (except fot the M2M studio part) does nos seem to be monitored regularly. :exclamation:


#5

Yes but no answer after two mails… I will phone to my distributor…


#6

We encountered the same issue and already reported it. It is confirmed by wavecom and should be corrected in Oasis 2.33, the release after the upcomming one.


#7

Thanks.

Do you known when Wavecom plans to release it ?

Or do you known if Wavecom can release a patch to correct this ?


#8

The response mentioned that the release date is yet unknown. Wavecom proposed to use r73a for the time being. No mention of patches or workarounds.


#9

Ok. Thanks !