Unable to Start Legato on WP7702 on Legato 14.1

I’m trying to update my WP7702 for production like I have done with the WP85 for all of our previous builds. We had issues with role back of the WP85 so we build a full SPK that includes the correct version of Linux (built by Sierra), the modem firmware and Legato with our apps. I can’t get this to work on the WP7702.

Every time I fwupdate download either a full combined SPK or just Legato with my apps as a .cwe the WP7702 won’t start Legato. The only way I can get my apps to run is by using the update <file.upate> command.

I have captured console for both situations which I have uploaded.
Legato Starting.txt (21.6 KB)
Legato Not Starting.txt (25.7 KB)

Here is my process:

  1. Run a fwupdate WP77xx_Release14.1_GENERIC_GCF_PTCRB.spk this is meant to upgrade the factory installed version of Legato to V14.1.
  2. Build my apps with Legato used Leaf swi-wp77_5.0.1 to get version 14.1.
  3. Covert my update file to .cwe using systocwe
  4. Run fwupdate on my .cwe file.

After this Legato won’t start.

I would suggest you to modify wifi.sdef and then “make wp77xx” instead of using systocwe:

@jyijyi I’m not following. I don’t have WiFI on my custom board and I wasn’t using it with the WP85 either. Why do suggest using “make wp77xx” instead? I successfully used the systocwe method with the WP85.

If you don’t need the wifi stuff, you can comment out in the wifi.sdef file

“make wp77xx” is a way to compile out the legato.cwe, that is why I suggest this.

I never used systocwe, so I cannot comment why it is not working on your side.

@jyijyi Ok thanks. I’m still not following your suggestion. Can you provide some more details? What is the issue with using systocwe?

I don’t know, I never use systocwe as “make wp77xx” is already working fine for me to build the legato.cwe

@jyijyi I tried that and I still get the same result. Any other thoughts?

how about this default legato.cwe by “make wp77xx”?
i.e. not modifying anything in the legato source

How about the official legato image in here?


Yes, the official image works, as I detailed in my first post. I need my apps to work for production.

how about the default legato.cwe by “make wp77xx”?
i.e. not modifying anything in the legato source

how about the image in leaf?

@jyijyi Moving to the ./leaf-data/current/wp77-legato and running make wp77xx got everything working.


Turns out the actual issue is the size of the .cwe image. See this post WP7702 R14.1 Available Memory Mismatch