Swiflash Issues

I’m am in the process of migrating from WP85 to WP7702. I have upgraded to using Leaf to provide the toolchain and WP SDK for the WP7702.

During this migration I have been having a lot of issue with getting swiflash to download SPK images to the WP7702. I have swiflash v5.2 installed on my Linex VM on my Intel MacBook. I haven’t had any issues with programming the WP85’s for the last 3 years.

I tried to program 5 WP77XX with the Sierra SPK and an SPK I built but swiflash moves to the Downloading phase and then just prints dots. The image doesn’t get uploaded and there is no other details. Is there any way to debug or follow what swiflash is doing or what’s going wrong?

I really need this to work as we are no longer building with the WP85 due to the EOL and pending 3G sunset.

In order to get around this issue I restored to using scp to transfer the SPK to /tmp on the WP77XX and running fwupdate download /tmp/<fileName> which I have never had to do before.


how about doing AT!BOOTHOLD first and then run the swiflash?

I tried that too as I found this post Swiflash failure in custom board which you suggested that. Unfortunately it didn’t work. That post pointed me to the scp method that I ended up using.

Any other things I can try? As I said the swiflash WP85 works fine.


how about using fwupdate in leaf shell?


I can try that but my understanding is that fwupdate only works with CWE files. Am I incorrect?

.spk should be also working

BTW, for your linux machine using swiflash, did you install the MBPL USB driver or GobiSerial driver?