Thinkpad EM7455 tcp/ip crash and driver issue


#1

I have a Carbon X1 (20HQ), with a Sierra Wireless EM7455 Qualcomm Snapdragon X7 LTE-A card.

This card has the tendency to somehow “temporarily destroy” the tcp/ip stack on my laptop, and I have to restart to be able to get connected to the network again (even wifi). What happens is that I use the cellular, and when I am finished using it, I disconnect normally. The next time I use it, it will connect - and say it is connected - but there are no Internet or other network access. Not possible to ping ip-addresses or domain. Wifi will not work either now, and the only help is to restart the pc. I’ve tried a lot to avoid restarting; network troubleshooter, ipconfig release/renews/flushdns, disabling/enabling the adapter, various commands related to the network device - but the only fix is to restart the pc - which is a pain. I’ve tried disabling all the power management, sleep of the device also, but no help. The issue does not always happen, but often enough - and many times in customer meetings - which is very troublesome.

I find these in the event log, which I think is related:

“Miniport Sierra Wireless EM7455 Qualcomm Snapdragon X7 LTE-A, {7afa6e46-4c68-4304-981d-8f4c1b5d6f76}, had event Fatal error: The miniport has detected an internal error”

Normally such situations are resolved by updating drivers, but it seems that Windows is forcing its own drivers for this device. It uses some generic drivers issued by Microsoft - and not Sierra drivers.

There are no drivers available for the card on Lenovo pages for this pc, and the drivers that I download directly from Sierra web pages “are not used” even if I have installed them. If I manually say “Update driver” and “Browse my computer for driver software” and point to the Sierra drivers that I downloaded, Windows says that “The best drivers for your device is already installed” and displays “Generic Mobile Broadband Adapter”. I have even tried to “Have disk” and forced the Sierra drivers, but the device will not work at all then.

Some questions:

  1. Anyone knowing whats going on here with regards to the drivers? Anyone found drivers that will actually replace the Windows generic ones?

  2. Anyone having experienced the same issue as me with regards to having to restart the pc to get network working again?


#2

I’d guess the OS is Windows 8.1 or Windows 10? WWAN modules for Windows 8 and 10 use Microsoft MBIM interface which uses Microsoft inbox driver naturally.

You can find the latest driver Build 4828 from Lenovo website below. The driver package included firmware package for different carriers as well and should automatically update your EM7455 firmware.
https://support.lenovo.com/ca/en/downloads/ds112204