The module Resets and DOTAdont install the file


#1

Good afternoon, im trying to do some DOTA but im having troubles. Im using a Q2687H Classic.

First of all i tried with the DOTA example wich came in the M2M Studio. It works jus fine, so i followed the same steps that this do.

This are the steps i made:

  1. Initialize the A&D memory.
  2. I download a .dwl file from a FTP server using the wip_read function (ive checked that the size of the downloaded file and the original are the same. The DOTA examples was tested with this same file, so is not currupted). 3_ Write the file in memory when is being downloaded with the adwrite function. Ive checked the result of this funtion and is always OK.
    4_I finalize the cell with a OK result.
    5_Install the cell.
    Then, i reached at the Handler and the module resets, unfortunetly the .dwl doesnt install in my CPU. Why is that?

I`ve seen similar problems in the forum but i think not exactly as this. I really aprecciate some help.
Thanks for advance!.
Nicolas.


#2

Sounds like the file is getting corrupted during the download and/or writing to A&D memory, doesn’t it?

Have you checked the startup reason when the module restarts?


#3

I solved it!, it was a stupid problem who took me all the afternoon to figure. I was writing two times the same data, that was all.

Thank u so much for the reply. If anyone have the same problem, chek how you`re writing the File in memory.

Best Regards.
Nicolas.


#4

Hi nicool

Im having a similar problem. Even when using the DOTA sample I get an install error on restart.

Does DOTA work with any firmware and OS version?

Thanks


#5

Hey

Dont worry about previous post, I fixed the problem. Using the same firmware and application OS but updating OpenAT version and M2Mstudio version.

Thx


#6

It has certainly been supported by all Open-AT versions from 3.03 on.

Exactly the same rules apply to loading an application via DOTA as to loading it via AT+WDWL; viz, the application must be built for the specific version of firmware+open-at installed on the device.

I did once (and only once) have a .dwl file that would load via AT+WDWL but not via DOTA; but rebuilding fixed it - so there must just have been something wrong with the build.


#7

From experience… one possible cause of this adl_adInstall-is-fine-but-installation-fails-on-reboot behaviour is having a version mismatch between the downloader (dwl.dwl) and the OS firmware. Verifying that the downloader is as recent as the OpenAT firmware is A Good Thing ™.


#8

Isn’t adl_adInstall supposed to verify that the image is “valid” before attempting to install it?
Doesn’t that include checking that it’s the right version?


#9

Hi

I am having problems installing an application from the A&D previously downloaded and successfully installed.

I download the application from an ftp and install successfully but leave the application in the A&D for future backup. When I subscribe to that A&D cell it subscribes successfully and I read the info of the cell(adl_adinfo), the size of the cell is correct and the cell is finalized but when I run the adl_adinstall on the cell the module resets with an ADL_INIT_DOWNLOAD_ERROR.

I have tried putting the UART in AT mode before installing and also tried disabling Unso responses and neather helps…does anyone know how to fix this?

Thanks
Charl


#10

What are you actually trying to achieve here?


#11

Hi

I want to leave a default application in the A&D for incase a DOTA fails or I load a bad application through DOTA which disables the bearer function or if the unit ends up in some bad loop which disables it from doing a DOTA update. I can the command the unit to reinstall the default App with an sms or if the unit had no contact with the server for a few day it knows to load the default App from memory. The default app just enables the unit to redownload the actual app from the ftp. Its a last resort for if the unit fails in some or other way.

Hope this makes sense


#12

So that requires that you have sufficient A&D space to store two complete applications?


#13

Yes it does, I have enough space. I put the default app in A&D cell 0 and the main App in A&D cell 1


#14

Here is a workaround for the problem.

I have found that it is not possible to install the same application from the A&D twice, after the first install from the A&D Cell ID the file is useless.

So what I do is download the Default App into Cell ID 0 of the A&D with DOTA, but not install it. Then install the Main Application on the module. When using DOTA to download the Main Application, download to Cell ID 1 and install.
If the Main Application is giving problems, I have the Default Application for installation as backup. This is done by copying the Default App from Cell ID 0 to Cell ID 1, and then installing Cell ID 1. This is done so that the Default App in Cell ID 0 is still usefull for later use if it is needed again. The process can be repeated whenever the Main App is not opperating as wanted.

Maby I am the only crazy person that wants a backup application on the unit for if the Main Application fails to DOTA.


#15

Have you had this verified as an issue by Sierra Wireless?

If this is true, then it really should be documented - there is currently no indication that installing from A&D memory is “destructive”


#16

Hi

I have word from my supplier that the A&D has a built in CRC and that it has something to do with that. I am not sure how exacly it works. I have tried and tested multiple times and in different ways and its not possible to install from the same file in the A&D more than once. The workaround that I explained is the easiest way I could find of doing it.

Thanks for the help anyway.


#17

No, that doesn’t really explain it, does it?!

Please push your supplier to have Sierra Wireless at least document this properly - and, preferably, fix it!